Virtual box cant open machine

hi , after i start virtual machine i got this error :
Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver is either not loaded or not set up correctly. Please try setting it up again by executing


as root.

If your system has EFI Secure Boot enabled you may also need to sign the kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load them. Please see your Linux system’s documentation for more information.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

i tried to fix it with " sudo /sbin/vboxconfig "

here is resualt Stopping VirtualBox services. Starting VirtualBox services. You must sign these kernel modules before using VirtualBox:
vboxdrv vboxnetflt vboxnetadp
See the documentation for your Linux distribution… Building VirtualBox kernel modules. failed: modprobe vboxdrv failed. Please use ‘dmesg’ to find out why.

There were problems setting up VirtualBox. To re-start the set-up process, run
as root. If your system is using EFI Secure Boot you may need to sign the
kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load
them. Please see your Linux system’s documentation for more information.

Looks like your VB modules are unsigned.

You might try taking a look at this:

1 Like

You can find out if the modules are actually signed.

find /usr/lib/modules/$(uname -r) -name vboxdrv.ko\* -exec modinfo {} +

If so, you will need to enroll the signing certificate. I assume you did not install VirtualBox from the rpmfusion repository. Therefore I don’t know where that certificate may be stored on your system.

if i turn off secure boot its will be fix ?

and if i turn it off its not going to demage my system ?

im new on linux can you help me to fix it step-step

That is one way to solve the problem, yes.

1 Like

i turn off secure boot and now its work without any problem
thank you :slight_smile: you save me to stay on fedora

1 Like

If you installed VirtualBox from rpmfusion you also can do the steps here to create a key and then create signed modules.

  1. sudo dnf install akmods
    which will install the akmods package if not already installed
  2. sudo kmodgenca
    which will create a unique key for signing packages that are created using akmods.
  3. sudo mokutil --import /etc/pki/akmods/certs/public_key.der
    which will tell your uefi bios that there is a new key to import. This command will ask for a password that you create here and use in step 4
  4. reboot
    The bios will bring up a mokutil screen that you use to import the key just generated into bios for use by secure boot
  5. sudo akmods force
    which will rebuild all kernel modules and sign them with the key just generated.
  6. reboot
    this time, with secure boot active, the signed kernel modules should be properly loaded

All steps only need to be done once. As long as each has completed successfully future updates of the system will automatically rebuild all needed kernel modules to match the currently or newly installed kernels.

We don’t know if the original poster installed VirtualBox from rpmfusion. If it was downloaded from you need different procedures. The command /sbin/vboxconfig was mentioned in the first post, and that command is not provided by the rpmfusion version.

I edited my post to reflect installing from rpmfusion. Thanks.

I don’t know if the problem is the same as the one I’m experiencing. I also installed VirtualBox from rpmfusion, which worked perfectly a few weeks ago. After some recent updates (but I can’t say which one), I cannot start any existing VM or any newly created VM. The error is always the same:

The VM session was aborted.

Result Code: 
NS_ERROR_FAILURE (0x80004005)
ISession {c0447716-ff5a-4795-b57a-ecd5fffa18a4}

and I don’t have SecureBoot enabled.

Please let me know if I have to start a new thread.

That command is not needed with the rpmfusion version. The module is compiled and activated by akmods when using the rpmfusion install method.