VirtualBox not working anymore after upgrade to Fedora 32

After upgrading to Fedora 32, VirtualBox fails to start VMs:

Failed to open a session for the virtual machine
The VM session was aborted.
Result Code: NS_ERROR_FAILURE (0x80004005)
Component: SessionMachine
Interface: Session {…}

I tried dnf reinstall VirtualBox (from rpmfusion), which succeeded but immediately caused SELinux alerts:

SELinux is preventing systemd-modules from open access on the file /sys/firmware/efi/efivars/SecureBoot-[…]
avc: denied { open } for pid=236949 comm=“systemd-modules” path=“/sys/firmware/efi/efivars/SecureBoot-8be4df61-93ca-11d2-aa0d-00e098032b8c” dev=“efivarfs” ino=26700 scontext=system_u:system_r:systemd_modules_load_t:s0 tcontext=system_u:object_r:efivarfs_t:s0 tclass=file permissive=0

I wonder if the kernel modules are not properly installed, and if SELinux is blocking their installation, or if that is unrelated.

dnf info *virtualbox* shows kmod-VirtualBox-5.6.8-300.fc32.x86_64 is installed, but the text is in red, unlike other package names in blue. I don’t know what the recent addition of color coding means in dnf.

1 Like

try and install setroubleshoot package, i will notify you when it trigger a event might provide some more information

I have the setroubleshoot package installed and the above messages are reported in it.

I also tried reinstalling VirtualBox with SELinux in permissive mode. Of course the same alerts were issued without enforcing, but the result is the same: VirtualBox still won’t start VMs.

Other ideas?

1 Like

Workaround found: disable 3D acceleration in the settings for the guest VM

This allows the VM to start. Part of the issue might be that there is no official VirtualBox package yet for F32 so the one built by rpmfusion might have dependency or build issues.

In other words, it looks like early adopter issues. In the past, I had delayed upgrading Fedora since certain packages blocked it by not having builds for the new release, and VirtualBox had been one of these.

1 Like

I have the same problem, and I installed it and tested it in addition to other equipment in other equipment, but it showed the same result. I also have a lot of thoughts. Add my question list.

It is an unpleasant surprise, but I expect that the issues will be resolved when VirtualBox releases a package with support for F32.

Previously, that would take a few weeks after a new Fedora release, which would block my upgrade until it became available. This time it seems rpmfusion built a package for F32 right away, but clearly it has problems.

I doubt there is much to do other than wait, unless you can help with development.

if you disable selinux , it works ?
ATM, we don’t support running VirtualBox with selinux enabled, solution is disable selinux.

It worked fine with SELinux on Fedora 31, so I don’t think that’s the issue. The bug report behind that recommendation is really old (2016). Although, there have been a number of SELinux issues that need ironing out on Fedora 32.

yes , sorry , maybe I should change the wiki page .
But if you disable selinux , it works ? i.e. is a SELINUX bug (again) ?

Thank you

I just installed it to test… at first I thought it did goes fine but then I see in the terminal:

WARNING: The vboxdrv kernel module is not loaded.
Either there is no module available for the current kernel (5.6.10-300.fc32.x86_64) or it failed to load.
Please try load the kernel module by executing as root

           dnf install akmod-VirtualBox kernel-devel-5.6.10-300.fc32.x86_64
           akmods --kernels 5.6.10-300.fc32.x86_64 && systemctl restart systemd-modules-load.service

         You will not be able to start VMs until this problem is fixed.

Well, I had not done some update… So I did them.
While rebooting, I have seen it build akmod module, and I am kind of now remembering that akmod install it stuff at reboot you have to reboot after installing virtualbox I think.
I have seen about vboxdrv starting and I expect it to works now.

Indeed the message is gone now…
but also [paul@localhost ~]$ uname -r

I have started a new VM for Fedora 32 Cinnamon Live … working fine.

No. I tried permissive mode, and VirtualBox still fails to launch VMs if 3D acceleration is enabled.

kernel: EMT-0[4958]: segfault at 7fabac2f6000 ip 00007fab741ccbb7 sp 00007fab775fdb80 error 7 in[7fab741bb000+27000]

I already have akmod-VirtualBox installed. Reinstalling VirtualBox does bring up SELinux alerts:

SELinux is preventing systemd-modules from open access on the file /sys/firmware/efi/efivars/SecureBoot-8be4df61-93ca-11d2-aa0d-00e098032b8c.

I don’t know if the problem is with VirtualBox / 3D acceleration, or SELinux policy, or both, but something is not working.

I am looking at:

There seems to exist a log (might be for each machine)…

Also, I am able to reproduce here.

1 Like

Good find. That ticket seems like the same issue. Interesting that this started only after upgrading to F32.

And I have a message that say that Fedora does no support for VirtualBox…

After reading:
I was able to extract:
Message: Process 15014 (VirtualBoxVM) of user 1000 dumped core.

            Stack trace of thread 15045:
            #0  0x00007f21e2d40bb7 ShaderInitLib ( + 0x1dbb7)
            #1  0x00007f2209133abd _Z15vmsvga3dPowerOnP11PDMDEVINSR3P8VGAStateP10VGASTATER3 ( + 0xe5abd)
            #2  0x00007f2209120ae9 _Z15vmsvgaR3PowerOnP11PDMDEVINSR3 ( + 0xd2ae9)
            #3  0x00007f22090ab3d4 vgaR3PowerOn ( + 0x5d3d4)
            #4  0x00007f2237250387 pdmR3PowerOnDev ( + 0xf2387)
            #5  0x00007f223729ce68 vmR3PowerOn ( + 0x13ee68)
            #6  0x00007f22372a7928 VMMR3EmtRendezvous ( + 0x149928)
            #7  0x00007f22372a350b vmR3ReqProcessOne ( + 0x14550b)
            #8  0x00007f22372a4461 VMR3ReqProcessU ( + 0x146461)
            #9  0x00007f22372a2282 _Z25vmR3EmulationThreadWithIdP11RTTHREADINTP6UVMCPUj ( + 0x144282)
            #10 0x00007f2266dde044 rtThreadMain ( + 0x188044)
            #11 0x00007f2266e9466e rtThreadNativeMain ( + 0x23e66e)
            #12 0x00007f2267180432 start_thread ( + 0x9432)
            #13 0x00007f22670a79d3 __clone ( + 0x1019d3)

To be honest, that does not means much to me.

I use:

[paul@localhost ventoy-1.0.09]$ inxi -G
Graphics: Device-1: Intel 8th Gen Core Processor Gaussian Mixture Model driver: i915 v: kernel
Display: x11 server: Fedora Project 1.20.8 driver: modesetting unloaded: fbdev,vesa
resolution: 1280x1024~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.0.6

and you?
So we should wait version 6.1.8 of VirtualBox.

I use the nvidia driver:

Device-1: NVIDIA GP108 [GeForce GT 1030] driver: nvidia v: 440.82
Display: x11 server: Fedora Project 1.20.8 driver: nvidia
unloaded: fbdev,modesetting,nouveau,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce GT 1030/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82

It’s great that 6.1.8 is released and should become available soon in Fedora but I don’t see any mention of a similar bug in the changelog:

VirtualBox 6.1.8 update is now available from RPMFusion. It now succeeds in starting VMs with 3D acceleration enabled. I haven’t tested extensively, but it’s already an improvement.

Note that the VirtualBox developers are working on a build to properly support F32, and that is expected to be released in a few days.

1 Like

It is not currently being applied, and it will take longer.