VirtualBox (from rpmfusion) cannot open machines with recent updates

I’m starting a new thread because this other one Virtual box cant open machine seems to have a different configuration.

I installed VirtualBox from rpmfusion, together with requirements.

With this old configuration it was working perfectly fine:

Linux xps-fedora 5.18.13-200.fc36.x86_64 #1 SMP PREEMPT_DYNAMIC Fri Jul 22 14:03:36 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

VirtualBox Graphical User Interface Version 6.1.34_rpmfusion r150636

After recent updates, even the ones from a week ago, but it could be even earlier, and even with the ones from today, I cannot open VMs anymore with VirtualBox (the existing ones, and the ones that I create from scratch):

Linux optiplex-fedora 5.19.11-200.fc36.x86_64 #1 SMP PREEMPT_DYNAMIC Fri Sep 23 15:07:44 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

VirtualBox Graphical User Interface Version 6.1.38_rpmfusion r153438

This is the error I constantly get

The VM session was aborted.

Result Code: 
NS_ERROR_FAILURE (0x80004005)
ISession ...

Any clue, please? (besides, of course, not applying new updates in the working configuration, but that does not solve the problem in the machines where the updates have already been applied).

Any mention of USB in that error message? I just tried booting Fedora 37 Workstation under VirtualBox and had to switch to USB 1.0 in settings for that machine before it would boot.

Here’s the full error text:

Failed to open a session for the virtual machine **Fedora 37 Workstation Clone**.

Implementation of the USB 2.0 controller not found!

Because the USB 2.0 controller state is part of the saved VM state, the VM cannot be started. To fix this problem, either install the **'Oracle VM VirtualBox Extension Pack'** or disable USB 2.0 support in the VM settings.

Note! This error could also mean that an incompatible version of the **'Oracle VM VirtualBox Extension Pack'** is installed (VERR_NOT_FOUND).

|Result Code:|NS_ERROR_FAILURE (0x80004005)|
| --- | --- |
|Interface:|IConsole {872da645-4a9b-1727-bee2-5585105b9eed}|

How did you get the full message? Have you run VirtualBox from the command line?

Oh, I noted now in your error message that your problem with USB 2 is due to the absence of the extensions. I have extensions installed so it shouldn’t be due to that…

I guess it’s because of this (btw: JoeAverage is me):

you could temporary use VB 7 Beta (newer) or a test build

I’m running Fedora 37 Beta, homebrewed kernels 5.19.x with Debug On again and VB 7 Beta here without trouble (VM Guests: Win 8.1, win 10 accessing the raw partitions)

Thanks for the hint.
But does this mean that Fedora ships a kernel with CONFIG_DEBUG_KERNEL set?

yes !

you could easily prove it yourself:
under /boot are the kernel config files from the installed kernels usually named “config-5.19…”

The default config for the fedora kernel contains this

1 Like

That full message is exactly the way the error was presented, in a small pop-up window.

I run VirtualBox from the system menu.

Apparently, it was completely my fault: I did not notice that VirtualBox had been upgraded to a new version 6.1.38 and I had forgotten to download and upgrade the extension pack accordingly by downloading manually

In my defense, I could say that in other distributions (Arch and Ubuntu) the extension pack is provided together with the packages from the repositories, while this is not the case for rpmfusion. :innocent:

I think we can close this issue, hoping that it reminds others not to make my same mistake :wink:

It doesn’t auto download the extension pack when using the virtualbox repo either you have to manually download it.
Glad you have it working now. :smiley:

1 Like

Yes, but as I said other distro do that automatically with proper packaging

Maybe you could file a bug report with rpmfusion to suggest they do as you wish. The update without also updating the extension pack seems like an oversight.

I doubt they’ll listen. I think they do not ship the extension pack at all for licensing reasons…

1 Like

VirtualBox Extension Pack uses “Personal Use and Evaluation License (PUEL)” a nonfree restrictive license. See VirtualBox_PUEL – Oracle VM VirtualBox § 2 Grant of license. for details.

1 Like

And just in case, I documented it all: VirtualBox in Fedora Linux | Lorenzo Bettini

Can you double check, because as I recall the extension is downloaded for one purpose.
It’s proprietary.

If it would not be proprietary, we would be allowed to provide the feature along the regular VirtualBox package distribution…

Just for the sake of it.

You should better use KVM that has such feature (USB redirection) enabled by default and way better integrated with Fedora…

@lorebett does not say anything about whether the licensing is proprietary, since he said it was necessary to enable the rpmfusion-nonfree repo. That by itself should tell anyone who is aware that it cannot be distributed directly by fedora which implies restrictions on distribution within the US.

The virtualbox-guest-additions package does not appear to contain proprietary code. It comes directly from fedora, while the entire package set for installing VirtualBox comes from rpmfusion since VirtualBox is proprietary.

# dnf install VirtualBox virtualbox-guest-additions
Last metadata expiration check: 4:14:44 ago on Thu 24 Nov 2022 04:21:13 AM CST.
Dependencies resolved.
 Package                                   Architecture          Version                        Repository                             Size
 VirtualBox                                x86_64                7.0.2-1.fc36                   rpmfusion-free-updates                 24 M
 virtualbox-guest-additions                x86_64                6.1.40-1.fc36                  updates                               1.4 M
Installing dependencies:
 VirtualBox-kmodsrc                        noarch                7.0.2-1.fc36                   rpmfusion-free-updates                914 k
 VirtualBox-server                         x86_64                7.0.2-1.fc36                   rpmfusion-free-updates                 20 M
 akmod-VirtualBox                          x86_64                7.0.2-1.fc36                   rpmfusion-free-updates                 20 k

Nice try, but that’s not the reason why virtualbox isn’t in fedora.

(hint: RPM Fusion project coordinator speaking).

The reason why virtualbox isn’t in fedora is because it relies on external kernel module (akmod-virtualbox) that is forbidden in Fedora.

The components that are distributed in RPM Fusion free section are totally FLOSS. That’s apply for virtualbox. But some others components are forbidden in Fedora for the reason you have mentioned.

The extensions are not at all mandatory to use VirtualBox, most end-user does not need them.
And as it’s not FLOSS, as such requires a separate means to fetch.
See also Howto/VirtualBox - RPM Fusion

If you want to ask for a better advertising that the extensions are explicitly used in a given VM and a download is requires, this is a legitimate question that should be forwarded to upstream.

We are not entitled to make arbitrary changes to software. So if you have idea about how changes should be made, please ask upstream projects ( instead.
Staying Close to Upstream Projects :: Fedora Docs

1 Like