Virtio drivers Problem in Win10 on Fedora36-QEMU/VirtManager


I installed a Windows 10 virtual machine in QEMU/VirtManager on Fedora 36.

Unfortunately it hasn’t a connection to the internet.

I already installed the Virtio-Drivers from here:

I tried the latest version which is 221 and version 217. Both didn’t work. I also tried the msi-File. Same result.

In the settings of VirtManager I tried NAT+virtio, NAT+e1000, NAT+HypervisorStandard, Macvtap+e1000, Macvtap+virtio. Nothing worked.
In Windows Device Manager the Network Adapter is shown with a yellow triangle and further installations are required. (With installed driver)

Before I installed the drivers, there even wasn’t a Network Adapter except a lot of “WAN Minioport”-variations.

The ISO I used to install Windows 10 was Win10_21H2_German_x64.iso

What can I do to get Internet in the Win10 VM?

Thank you in advance.

Use the English version of windows 10.

1 Like

That was the solution! Thank you!!

After installation I changed the Language to German and it continued working. So I have now a German Windows 10 with working Network as KVM. I’m very happy!

1 Like