No network connection for Windows 10 in Gnome Boxes

Hi all,

I installed Windows 10 in Gnome Boxes because I want to get rid of VirtualBox. Everything works nice, I can even access my USB headset, etc beside the network. Windows 10 doesn’t show any network device. This means I also can’t access the Internet with Windows.

Any idea what could be wrong?

Thanks a lot!

This might help:

c. Install the virtio driver in the Windows guest for optimum network performance in the VM, they can be found here

Gnome Boxes and Windows Guest | GExperts Inc

Thanks, sounded promising but unfortunately didn’t worked for me.

I followed the link until I got there:

Added the dnf repo and installed the “virtio-win” package on my Fedora machine. Additionally I installed the “virtio-win-guest-tools.exe” on the windows system. But Windows still don’t find any network device :frowning:

This are the Gnome Boxes logs, I don’t see any obvious error but maybe someone else sees something?

Even that it sounds super strange, this was indeed the solution:

Initially I used the German version of Windows 10. Now I downloaded the English version, installed it the same way in Gnome Boxes and the network works out-of-the-box.

If someone knows or find out why, this would be still interesting. But the problem as such is solved for me. :slight_smile:

It is difficult with closed source software. I imagine that boxes just was tested with the English version. Is the Win10 version you use able just to install German language files?

For the records, I have the same problem for the first time. I’ve never had any connection problem with regular Windows 10 installations, but now I’m testing a peculiar version of Windows called Windows 10 Lite. It is in English, but it’s a lite version so some parts have been removed.

Without Internet connection and no way to share files between host and guest I’m stuck.

As noted in the solution post above, the regular English language version of windows 10 worked. Your version is different even if it is also English.

It is long since I worked with Windows. From the Linux perspective I just would tell you, try to install the complete Networking part you have with the working version.

on the download page you first select the multi edition iso, and then it asks for language you use the english one (not english international)

Did you check while downloading that you not take the international one?

The solution seams simple, you might just have to switch to the “Virtual Machine Manager” and do the following:

Since this topic pops in google, I’d like to add an easier solution:

Uninstall the “Red Hat VirtIO Ethernet Adapter” in the device manager, after that, simply search for new hardware devices.