Virt-manager libvirt, F37 Host and Guest, microphone does not work on guests

Host is an ASUS Vivobook, Ryzen 7. Sound device on guest is set to ich9, also tried the ich6 option. which works equally well for sound output but still no mic. The AC97 option produces crackly sound so did not try that with the mic.

Virtual Machine Manager 4.10 powered by libvirt. Host and guests F37 Kernel 6.1.13-200 everything updated a few minutes ago.

Sound output works on guests. The webcam works after attaching the USB device.

Microphone works on the host. settings->input->input device, the vu meter bar bounces up and down with sound.

Guest settings->Input->Input Device says, Line In - built in Audio. The vu meter bar underneath shows no movement.

Discussions found elsewhere suggest that the mic works by default, so that is the expectation, i.e. that there are no other settings to be adjusted.

Have you made an usb redirector for your webcam. So that the webcam is visible if you start the guest os.
I could imagine so the system will recognize it.

So far, I do not notice a general method to redirect only the Mic input from the Host to a VM guest.

There are a few know good methods:

  1. Use USB device. USB redirection to VM guest works. I use virt-manager with that occasionally. USB Webcam, USB headset, USB LAN, etc.

  2. If the device is in a IOMMU group, that can be redirected to the guest also.

With notebook computer, some device might be readily redirectable - just look over the available list and try with care.

Yes, and the webcam works well. However, the guest does not see the microphone which is built into the laptop. The host sees it, but not the guest.

The mic problem also appears for another user who also has an ASUS laptop, so I ordered a couple of usb headsets. Your post and another on the Internet suggests this. It is not a perfect workaround as a group of people can not sit in front of a laptop and all yell at it. But it will do for now.

Clearly, none of the USB devices listed for redirection is the built in mic.

I do not know how the built in mic is handled as an I/O device or if it is part of an IOMMU group. In some of the discussions people have talked about pass through of the entire sound device, which would work for our purposes - if that would solve the mic problem. I have to look into that another time. I was hoping that there was a neat explanation for the laptop built in mic …

Add Hardware > PCI Devices > Chipset High definition audio controller or similar … I not tested it but I saw that i can select it.

Just to follow up here.

The suggestion to use a USB headset (and to capture that usb device) worked fine.

ALSO some updates later, and the issue in the original question has cured itself. The unit microphone now works as line in. That is great.

I didn’t manage to figure out how to capture the sound card, and stopped working on it when the head sets arrived.