Videos buffer or dont load

  Host: name Kernel: 5.1.15-300.fc30.x86_64 x86_64 bits: 64 
  Desktop: Gnome 3.32.2 Distro: Fedora release 30 (Thirty) 
  Type: Desktop Mobo: Gigabyte model: Z170X-Gaming 7 v: x.x 
  serial: <root required> UEFI [Legacy]: American Megatrends v: F22m 
  date: 03/09/2018 
  Topology: Quad Core model: Intel Core i5-6600K bits: 64 type: MCP 
  L2 cache: 6144 KiB 
  Speed: 3900 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 3900 2: 3900 
  3: 3900 4: 3900 
  Device-1: AMD Fiji [Radeon R9 FURY / NANO Series] driver: amdgpu v: kernel 
  Display: wayland server: Fedora Project 1.20.5 driver: amdgpu 
  resolution: 1920x1080~144Hz 
  OpenGL: renderer: AMD Radeon R9 Fury Series (FIJI DRM 3.30.0 
  5.1.15-300.fc30.x86_64 LLVM 8.0.0) 
  v: 4.5 Mesa 19.0.8 
  Device-1: Intel 100 Series/C230 Series Family HD Audio 
  driver: snd_hda_intel 
  Device-2: AMD Fiji HDMI/DP Audio [Radeon R9 Nano / FURY/FURY X] 
  driver: snd_hda_intel 
  Sound Server: ALSA v: k5.1.15-300.fc30.x86_64 
  Device-1: Intel Ethernet I219-V driver: e1000e 
  IF: enp0s31f6 state: down mac: #######
  Device-2: Broadcom and subsidiaries driver: brcmfmac 
  IF: wlp6s0 state: up mac: #######
  Device-3: Qualcomm Atheros Killer E2400 Gigabit Ethernet driver: alx 
  IF: enp8s0 state: down mac: ########
  IF-ID-1: virbr0 state: down mac: #########
  IF-ID-2: virbr0-nic state: down mac: ###########
  Local Storage: total: 931.51 GiB used: 76.21 GiB (8.2%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-08WN4A0 
  size: 931.51 GiB 
  ID-1: / size: 68.39 GiB used: 13.31 GiB (19.5%) fs: ext4 dev: /dev/dm-1 
  ID-2: /boot size: 975.9 MiB used: 199.9 MiB (20.5%) fs: ext4 
  dev: /dev/sda1 
  ID-3: /home size: 838.25 GiB used: 61.97 GiB (7.4%) fs: ext4 
  dev: /dev/dm-3 
  ID-4: swap-1 size: 7.87 GiB used: 755.7 MiB (9.4%) fs: swap dev: /dev/dm-2 
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: amdgpu temp: 37 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 717 
  Processes: 260 Uptime: 6h 32m Memory: 7.75 GiB used: 2.31 GiB (29.8%) 
  Shell: bash inxi: 3.0.34 

My issue:
Youtube videos buffer before loading
Youtube videos buffer after pausing
Udemy videos buffer indefinitely

What i tried:
Checked internet speed and installed wifi driver
Fresh install of fedora
Resetting Firefox settings to default
Using different browser (Brave and Chromium)
Tried playing in VLC (Still buffers before loading)
Tried installing FFMPEG

Please help. Fedora is my favorite OS and i spend a lot of time watching videos. If i can’t get this fixed i will have to switch OS, other forums have not been able to help me so i am hoping you guys can. :frowning:

First, Welcome to the community!

From what you have described and the steps you have already taken I am doubtful it is a software configuration problem on your Fedora machine.

To confirm this try reproducing the problem from a live usb of some other Linux distro. Another thing to check is the wireless router if you have access to that. Some routers have settings to ‘boost gaming’ or some such thing. What they actually do is slow down other traffic, leaving more bandwidth for games. That is almost always a bad idea on a home network. If you are on a public network it’s possible that some traffic is just throttled.

Just my thoughts after reading your post. If I didn’t lead you in the right direction, maybe someone else will have more insight than I do on how to dig deeper on an issue like this.

Hi; maybe a problem in drivers (recently I saw updates in xorg, kernel…) Why not change to XFCE? Nothing better than some themes to change the ugly aspect … I love the themes of Yaru, United …

Went back to windows for a bit but came back to try figure this out.

I don’t think its a router problem because it works fine on my laptop but not on my desktop. If it is a hardware issue then how do i debug it?

I have already tried pluggin in HDMI into mobo instead of GPU and that didn’t fix my issue.

Tried testing XFCE on live USB on both my laptop and desktop.
Laptop ran with no problems but desktop still buffers before videos :frowning:

Try to disconnect the wireless and test the wired connection if possible.
It can help to localize the issue.

Hey thanks for the reply. I tried using a new dongle as well and that didn’t help.

I just now tested ubuntu on my desktop and that works flawlessly so maybe my pc just isn’t compatible with fedora?

Glad i can get at least one distro running smooth but i would really like to get fedora to work or find out what i need to buy to become compatible.