Versalink C400 & Fedora 30 printer driver

Hi everyone
I have installed the latest driver for the printer above however when I run r xeroxprtmgr to set up the printe nothing happens. It works fine on a Centos machine. Any ideas?


Hello @nano007 …! Welcome to the community! Please do take a few minutes to go over the introductory posts in #start-here when you have the time. They contain lots of useful information.

[*]What happen when you type in terminal? xeroxprtmgr
[*]Do you have any message in console?
[*]What version packed did you install? rpm -qa | grep -i xerox

Maybe a related post →

Also you can search in log to get some usefull information:


When I run run the xeroxprtmgr I do not get any error messages. If I run not in su mode I run the xeroxprtmgr as root. The version is the latest: XeroxPrtDrv-5.20.652.4537-1.i586. If I run the program not in su I get /usr/bin/xeroxprtmgr: line 9: /tmp/Xeroxprtmgr.log: Permission denied. The log says:

[nano@localhost tmp]$ cat PrtDrvInstaller.log
Unable to detect printing subsystem
No protocol specified
xhost: unable to open display “:0”
Failed to grant lp xhost permissions

  1. Is your box i686 or x86_64? check with this command:

uname -m

and download the respective package to your computer type and delete the previous installed package if is necesary:

execute this command before to enable access:

xhost si:localuser:root

then execute:

sudo xeroxprtmgr

execute this command after to disable access:

xhost -si:localuser:root


The xhost program is used to add and delete host names or user names to the list allowed to make connections to the X server.

man xhost


Thank you.
I did what you suggested however the output stays the same.
When you download the driver - thank you for the link btw - PostScript Driver RPM package for Linux is required to make xeroxprtmgr working. Any idea how to check if my system has this driver installed by default? I am pretty sure that cups has been stalled correctly If this driver has not been installed do you know ehere I can find it.
Thank you again for your help

I think you don’t need special postscript, I follow the step without any issues:

See the description:


What I did:

  1. download the packed with my system structure from the link above:


  1. install it:

sudo dnf install *.rpm

  1. enable server with sudo

xhost si:localuser:root

  1. Run xeroxprtmgr as root to administer print queues


I also run xeroxprtmgr without sudo and get this screen:



Thank you for your quick reply. Very much appreciate it.
I followed your instructions to the letter however the output is still the same.
I installed the printer driver to a PC running Centos OS it works flawless.
Thank you anyway.