Using multiple command-line terminals (tty 1-5) on a m1 macbook air

I’m running fedora through a VM called UTM. It’s running just fine but I’m taking a class that requires me to use multiple command-line terminals. I’m aware that usually ctrl + alt + f1-5 will bring up one on windows machines. On mac I tried command + option + f1-5 and other variations with no luck. Am I missing something obvious? I’m using the latest stable work station fedora edition with a m1 macbook air running the latest MacOS.

Ouch, that is probably emulation, not virtualization in that case.

Either way, your VM client may not be capturing the keypresses. Does it have menus or something that allows it to send key combinations?

1 Like

Multiple command line terminals does not necessarily mean the bare terminal on the console as you get with ctrl-alt-f2-6 on linux. In fact I doubt that you can do so on a VM since that would likely get interpreted by the host and get you a console there and not on the VM.

A virtual terminal window is actually a command line terminal so just the virtual terminal window should work. You can open multiple windows or just multiple tabs in the same window.

2 Likes

Do you know if the keystrokes are being captured by the host OS, or are they being sent to the VM (but not the keys you expected)?

It might just be a matter of adding Fn to your key combo — also true of the default setup on many PC laptops these days, where the key defaults to doing the icon function instead of sending the F-key. (See How to use the function keys on your Mac - Apple Support .)

3 Likes

@mattdm Thanks for the reply, this seems like more of a UTM issue. I tried on parallels and it worked just fine. UTM is capturing my cursor and locking it to the window when I press control + option, going to try asking them about this instead.

1 Like

You can use this on the guest as a workaround:

sudo chvt 1

However be aware this is a problem of the hypervisor front-end, not Fedora specific.
So, it is best to ask on the relevant support channel.

1 Like

Switch tty sessions from desktop, in my case Ubuntu.
From https://ostechnix.com/how-to-switch-between-ttys-without-using-function-keys-in-linux/

In some Linux editions (Eg. from Ubuntu 17.10 onwards), the login screen now uses virtual console 1. So, you need to press CTRL+ALT+F3 up to CTRL+ALT+F6 for accessing the virtual consoles.

To go back to desktop environment, press CTRL+ALT+F2 or CTRL+ALT+F7 on Ubuntu 17.10 and later.


UTM on Mac defaults to using CTRL+ALT for capture / release of the cursor onto the VM. Under UTM > Settings … there is a check box

Use Command+Option for input capture/release

This will free up the CTRL+ALT to be passed onto the VM.

Finally, default mapping of Function Keys on modern Mac OS is to perform the Functions shown by the iCon on the keys (display light level, spaces, find, etc.), so the Fn Key needs to be pressed as part of the key modification sequence.

Therefore, to get to tty3 Hold Fn+CTRL+ALT Press F3

To Get to the Login GUI Hold Fn+CTRL+ALT Press F1

To Get to the Lock Screen / Current GUI Hold Fn+CTRL+ALT Press F7

I was going nuts, because I logged out and was smashing FnF1 and seeing the Login screen unchanged - What a World.

You are posting command key sequences for MACOS on a thread that was related to fedora commands on an m1 macbook.

It is quite obvious the key combinations within macos and within fedora linux are different.

This thread was also last active more than 2 years past with fedora about version 34.

When posting about macos commands please post on a forum that is dedicated to mac and not on a fedora linux forum

Looking at the original post problem, he is using the UTM application on he MacBook M1 (running Mac OS as the VMHost) and running a fedora as the OS of the VM. The Key strokes intended for the fedora VM (as with my Ubuntu Linux) are being intercepted by the UTM keyboard interface and on a MacBook M1 (or any modern MacOS hardware), accessing the Function Keys requires holding the Fn key on the keyboard as well. I posted this detailed reply here because it pops up high on Google Search responses – even though the complex way to make things work was first posted here 2 years ago. Not many of the other forums / responses describe the issue this clearly to a Mac user confronted with it. The answer also applies to most any flavor of Linux, including fedora. Hoping someone else tripping across this same issue can benefit from what I discovered.

So this then is the hardware interfering with the normal OS defined key mappings. That I did not understand.

Thanks for the update