Using archives as repos for EOL versions of Fedora

I am using Fedora 20 arm on a Banana Pi Pro (AllWinner A20 chip -SoC). This is similar to a Raspberry PI.
With this hardware, the only version of Fedora that runs is Fedora 20 arm.
As this version has reached EOL, the mirrors with the repositories are no longer available.
I have located pages that contain the archived files for Fedora 20 arm.

My question: How can I use the archive files as repos to be able to update my installed version of Fedora 20 arm?

I have tried writing the web page address for the archives into the /etc/yum.repos.d file without success. When I run “yum update” I still get the error message that says the repos (mirrors) could not be found.
Yes. I know that this is an old version of Fedora, but that is because, this is the only version that runs on this older single board device.
Any suggestions, advice, direction is appreciated. Thanks

How to use fedora archive site - #4 by vgaetera


Thank you for posting this link.
I looked at it and I must say that I have never used (or even heard of) the sed command.
The instruction that you posted have some language (arguments/options) that are not fully clear to me. I want to use these instructions. Please provide some details about how to use this command so that I can apply it effectively to be able to use the archives as repos for my system.
Thanks for your help with this.

The sed command in that linked post will make a few changes to any files that match /etc/yum.repos.d/fedora*.repo:

  • commenting out the metalink line, which is used to get mirror information from Fedora’s servers
  • uncommenting the baseurl line to use a fixed repo instead of the metalink
  • replacing the original baseurl values with the Fedora archives link

It is a single command with newlines. Copy and paste the whole thing into your terminal (there should be a copy button on the top-right when you mouse over the code block), not line-by-line.

If you want to see what it does without altering any files, you can remove the -i option. The output may be quite long. The -i option makes it write the modified output back to the files.

For more information on sed you can refer to the manual on your computer (man sed) or online. sed is a very old and powerful tool for editing and transforming text. Sometimes, it’s more convenient to give a sed command, than to write instructions like open this file, edit this line, then edit another line, etc.

1 Like

According to the output of the fedora arm-image-installer it seems that at least some of the allwinner devices are supported.

$ arm-image-installer --supported 
AllWinner Devices:
A10-OLinuXino-Lime A10s-OLinuXino-M A13-OLinuXino A13-OLinuXinoM A20-OLinuXino-Lime A20-OLinuXino-Lime2 
A20-OLinuXino-Lime2-eMMC A20-OLinuXino_MICRO A20-Olimex-SOM-EVB Ampe_A76 Auxtek-T003 Auxtek-T004 Bananapi 
Bananapi_M2_Ultra Bananapi_m2m Bananapro CHIP CSQ_CS908 Chuwi_V7_CW0825 Colombus Cubieboard Cubieboard2 
Cubieboard4 Cubietruck Cubietruck_plus Hummingbird_A31 Hyundai_A7HD Itead_Ibox_A20 Lamobo_R1 
Linksprite_pcDuino Linksprite_pcDuino3 Linksprite_pcDuino3_Nano MK808C MSI_Primo73 MSI_Primo81 
Marsboard_A10 Mele_A1000 Mele_A1000G_quad Mele_I7 Mele_M3 Mele_M5 Mele_M9 Mini-X Orangepi Orangepi_mini 
Sinlinx_SinA31s Sinovoip_BPI_M2_Plus UTOO_P66 Wexler_TAB7200 Wits_Pro_A20_DKT Yones_Toptech_BS1078_V2 
ba10_tv_box bananapi_m1_plus bananapi_m2_berry bananapi_m2_plus_h3 bananapi_m2_zero colorfly_e708_q1 
difrnce_dit4350 dserve_dsrv9703c i12-tvbox icnova-a20-swac inet86dz jesurun_q5 libretech_all_h3_cc_h2_plus 
mk802 mk802_a10s mk802ii nanopi_m1 nanopi_m1_plus nanopi_neo nanopi_neo_air orangepi_2 orangepi_lite 
orangepi_one orangepi_pc orangepi_pc_plus orangepi_plus orangepi_plus2e orangepi_r1 orangepi_zero 
polaroid_mid2809pxe04 pov_protab2_ips9 q8_a13_tablet q8_a23_tablet_800x480 q8_a33_tablet_1024x600 
q8_a33_tablet_800x480 r7-tv-dongle sunxi_Gemei_G9 

AllWinner-A64 Devices:
a64-olinuxino amarula_a64_relic bananapi_m2_plus_h5 bananapi_m64 libretech_all_h3_cc_h5 nanopi_a64 
nanopi_neo2 nanopi_neo_plus2 orangepi_lite2 orangepi_one_plus orangepi_pc2 orangepi_prime orangepi_win 
orangepi_zero_plus orangepi_zero_plus2 pine64-lts pine64_plus pine_h64 pinebook sopine_baseboard 

I suspect yours is the bananapro.
It also seems likely that it may be supported by a newer version of fedora, either workstation, server, or IoT.

While it may not be a 64 bit device you should still be able to use the armhf versions

Good morning
Thank you for your reply and information.
The board that I have is a Banana Pro and it is an older version.
The hardware specifications are:
Soc: Allwinner A20(sun 7i)
CPU: ARM Cortex -A7 Dual-Core 1 GHz (ARM v7 instruction set)
GPU : Mali-400MP2 Complies with OpenGL ES 2.0/1.1
SDRAM: I GB DDR3 (shared with GPU)
Power: 5V @ 2A MicroUSB
As I search on the web, I cannot find a web page for this specific board as LeMaker no longer lists this board. It was one of the first ones that LeMaker produced. It is not the same as the newer ones that are currently available.

This page from Armbian shows the board that i am using.

And this page shows the “LeMaker Banana Pro”

As far as I can tell, the only version of Fedora that was written for this board was 20 arm.
If there is a newer version, I am ready to try it.
Thanks again for the information.

I honestly do not know what versions would support that particular board.

I suggest that you have an extra SD card and try newer versions to see what may work. Fedora supported the 32 bit boards for at least 6 years after fedora 20 was released. They only ceased support for 32 bit on the intel processors at about release 32 or 33, but have continued on the arm architecture later than that.

The 32 bit (armhfp) image for fedora 36 is available here (probably until it is EOL in a few weeks.)
and fedora 37 & 38 only seem to have the 64 bit (aarm64) versions.

The problem with remaining at fedora 20 is that there are no updates or security fixes done after the release went EOL so the system would remain static after fully updated unless you were to update and compile packages for yourself.

Thank you Jeff V
I followed the link and downloaded the Fedora Workstation 36-1.5.armhfp.raw.xz.
I wrote it to an SD card using BalenaEtcher, as I have with other versions.
The Fedora 35 did not work.
This Banana Pro is very particular about what system will work.
So far, I have had success with Armbian and Lubuntu.
Fedora 20 (written for LeMaker Banana Pro) has worked, I just can’t update it, and I can’t add any new software because it is past EOL.
Still working on using archives as mirrors, and I have not finished that part yet.
Thank you everyone who has added comments.