I need help getting packages on Yum extender

I am a complete newbie to Linux and Fedora, I was able to install Fedora 20 on my desktop and logon (I have an old computer with i386 architecture and when I was looking for a version Fedora 20 seemed like it was the newest version I could run, when I found that Fedora 30 had a i386 version I tried that but could not get it to install) I would like to install some programs like Steam and a web browser but when I open Yum Extender I get an error message saying “can not retrieve metalink for repository: fedora/20/i386“ I found a forum post with the exact same issue (yum - Cannot retrieve metalink for repository: fedora/20/i386 - Unix & Linux Stack Exchange)
On this post the reply’s recommend accessing /etc/yum.repository.d and replacing https with http in the .repo files, I tried doing this but when i try and save the file it says “Can’t open file to write” when I click “open current folder as root” nothing seems to happen. I have also tried opening the file from terminal as root by typing sudo su then /etc/yum.repos.d/fedora.repo but it says “Permission denied”
Can anyone tell me how I can have these files, or another way to fix this error?

Hi @samh113.
Maybe you would like to try CentOS or Debian?  Currently there is no much support for so old versions of Fedora, as community seems to target the innovations, etc.

1 Like

This is because Fedora 20 is not active any more, and so the repositories do not exist. They may be archived somewhere perhaps.

If that is literally what you wrote, you tried to run the file /etc/yum.repos.d/fedora.repo. That won’t work, it is not a program but a text file. You need to type the command to run, and give it the file name as argument, e.g. gedit /etc/yum.repos.d/fedora.repo to use the editor gedit to do the editing.

That said, as mentioned by @FranciscoD and @vits95, Fedora has dropped support for the 32 bit i386 architecture in its current releases. It might not be a good choice of distribution for this particular hardware.