Using a tablet crash the Desktop on fedora 39 x11

I have a XP-Pen deco LW. In fedora 39, it shows on “wacom tablet” settings and using it causes a hard crash of the full desktop. It also shows twice in settings.

Disabling it from settings still interfere with the tablet. So i can’t use the gnome implementation or the original driver.

Until this get resolved, is there any way to disable the unofficial support built in in Fedora 39?

Note that his works fine in fedora 38.

Is there anything that can be done to fix this regression? I’m back on fedora 38 for the moment but i’ll have to update eventually and i need to be able to work.