Use DNF to upgrade the system to Fedora 34, but the system does not work


I use DNF to upgrade the system. After the upgrade operation, I can enter the system normally for the first time, but when I restart, I can’t enter the system again. I tried to use live for grub repair, but I couldn’t get into the system. My machine model is ThinkPad e450c

What happens when you try to log in now that you’ve restarted? We need much more detail than “I can’t enter the system again.” Are you getting error messages, and if so, what are they?

Thank you for your reply!After the restart, only two interfaces appear in the whole process. After a few minutes, the computer will restart automatically and try again and again!

What do you mean by “two interfaces”?

I think he meant “Two screens”. That thinkpad one and a blank screen later.

OK, what did you do from the live system and what happened? Did you try getting into grub at the beginning of boot and editing the command line to try booting into single user mode? If so, what happened. Just saying that it doesn’t boot isn’t helping; we need details.

How did you upgrade? What steps did you perform?

For future reference, here’s the official procedure for an upgrade: DNF System Upgrade.

Yes, I upgraded according to the steps on this link

Okay, my English is not very good. Most of the following words are translated using Google. I hope I can express my meaning clearly. I will describe my entire upgrade process and the problems encountered.
I followed the official upgrade process and used DNF to upgrade the program. No steps were missed. The entire upgrade process went smoothly. Use sudo dnf system-upgrade reboot to restart the system and complete the upgrade. At this point, the upgrade is complete and you can enter the system normally. This is what I said before, and it can enter the system normally for the first time.
After entering the system, I used sudo dnf update to complete the upgrade of the system application. After completing this step, I rebooted again. At this time, the problem occurred. After the computer restarted, it stopped at a blank screen after the thinkpad display was completed, and no follow-up booting was performed. I tried to press E to enter, but it didn’t work. After a few minutes, the computer automatically repeats, and so on. During the period, no error message broke out
I also tried to directly burn the KDE custom image of fedora 34 for installation, and it was the same situation. I also tried to burn the workstation image of fedora 34, but I couldn’t enter the system.

OK, when you logged in for the first time, did you try using the system or did you just run the update? I’m asking because we need to work out just when things started going wrong so that we know where to look.

Also, there are a number of boards here, dedicated to different languages. If there’s one for your native language, you might be better off asking there so that there aren’t any translation issues to worry about.

In fact, it is the same. After using the iso to reinstall the system, the first time you enter the system, even if you do not perform any operations, and then reboot, the same result will be obtained. I also tried fedora 35 beta and it was the same. But fedora 33 is completely fine.

Can someone help me?

You can share your bios configurations and can you see grub screen or you can’t. If you can see that you can boot into older kernel see if that helps.

For upgrade follow this

I cannot view grub, it should be said that the computer has not run to this point. The picture shows the configuration of startup items in my bios

Check your boot order. And quick boot mode to standard.

The content of the boot item shown in the figure is based on my hard disk as the first boot item

I tried to use fedora 34 workstation, but still cannot see grub and cannot enter the system. But when I use fedora 34 server to install, all operations are normal, so I should be able to determine that it is a system problem.

By installing all the spins of fedora 34 version, the system cannot be booted and the grub interface cannot be seen. The machine model is: ThinkPad E450C

You can try live boot into and try edit grub repair it