Boot and login problems in Fedora 34 Beta

I tried to upgrade from Fedora 33 to 34 beta on two laptops.

On #1 (Lenovo Thinkpad X230), which has a dual boot with windows 10, the upgrade removed Fedora from the grub boot screen, which now only show windows 10 as the only option.

I have tried to fix grub using a chroot from a live usb, but so far only an error message: “… is /dev mounted?” (yes, it is…)

On #2 (Lenovo Thinkpad W530) the upgrade went well, and I can boot into Fedora 34 - but only to be met with a login screen that continuously flickers after a few seconds, to say the finger print scan is not valid (in my language, which is Norwegian) under the password input field, making it impossible to log in.

I have logged in using a terminal (ctrl+alt +F2) and will upgrade there until (I hope) this issue is fixed.

Jus to let you know :slight_smile:

Regarding the finger-print issue, does it help after doing a dnf update ? I used to have finger-print logon issues at gdm from earlier Beta builds, but with the latest build, it is working fine for me.

1 Like