Updated to Silverblue 34 - now have no AptX support, and get hissing audio


I’ve been happily using Fedora Silverblue 33 for quite some time. I’ve been putting off upgrading to 34 for various reasons (such as the new inferior GNOME overview screen). With Fedora Silverblue 33, I used the pulseaudio-module-bluetooth-freeworld package from RPM Fusion to add support for additional Bluetooth codecs, such as AptX. I always used AptX with my Bluetooth headphones. I read that with Fedora Silverblue 34, Pipewire is being used in place of PulseAudio, and it apparently supports all of these fancy codecs natively. Sounds great…

So I went ahead and updated, and to my dismay, I no longer have AptX support. The Sound settings window only shows the following configuration options:

  • High Fidelity Playback (A2DP Sink)
  • Headset Head Unit (HSP/HFP)
  • High Fidelity Playback (A2DP Sink, codec SBC)
  • High Fidelity Playback (A2DP Sink, codec AAC)
  • Headset Head Unit (HSP/HFP, codec CVSD)
  • Headset Head Unit (HSP/HFP, codec mSBC)

Previously I had AptX as an option and could use that. And my headphones don’t even support AAC so I’m not sure why that is an option.

In addition to this issue, I’m now also getting a hissing noise in my headphones. It’s not bad when actively listening to something, but when I have no audio playing, the hissing is very clearly audible and bothers me. I didn’t have this problem with Fedora Silverblue 33.

Could anyone give me any advice? Is there some way to get AptX working with Pipewire and fix this hissing issue? Or was I misled regarding AptX support, and I should revert back to Fedora Silverblue 33?

Thanks in advance.

1 Like

according to this comment, they removed the aptX support from pipewire because of patent issues