How to install pulseaudio in Fedora 34 Silverblue

Hello. Today I upgraded to Fedora 34 Silverblue, and Zoom is not working fine with pipewire-pulseaudio (Sound routing problems on zoom meeting audio sharing (#1121) · Issues · PipeWire / pipewire · GitLab FWIW). I’d (sadly) need to use the real pulseaudio. How can I install that?

I tried rolling back to Fedora 33 but it seems that, after doing some layerings, I lost my last fedora 33 layer, and doing a rebase fails:

❯ rpm-ostree rebase fedora:fedora/33/x86_64/silverblue --reboot
2 metadata, 0 content objects fetched; 788 B transferred in 3 seconds; 0 bytes content written
Checking out tree 909e032... done
Enabled rpm-md repositories: fedora updates rpmfusion-nonfree-steam google-chrome fedora-cisco-openh264 code rpmfusion-nonfree-nvidia-driver
rpm-md repo 'fedora' (cached); generated: 2020-10-19T23:27:19Z
rpm-md repo 'updates' (cached); generated: 2021-04-29T00:48:43Z
rpm-md repo 'rpmfusion-nonfree-steam' (cached); generated: 2021-04-25T18:51:20Z
rpm-md repo 'google-chrome' (cached); generated: 2021-04-26T18:36:13Z
rpm-md repo 'fedora-cisco-openh264' (cached); generated: 2020-08-25T19:10:34Z
rpm-md repo 'code' (cached); generated: 2021-04-28T05:47:19Z
rpm-md repo 'rpmfusion-nonfree-nvidia-driver' (cached); generated: 2021-04-25T18:51:14Z
Importing rpm-md... done
Resolving dependencies... done
Checking out packages... done
Running pre scripts... done
Running post scripts... done
Running posttrans scripts... done
Writing rpmdb... done
error: Failed to update rpmdb (rpmtsRun code -1)

Also I tried to override without luck:

❯ rpm-ostree override replace pulseaudio
error: Non-local replacement overrides not implemented yet

Any ideas?


Have you tried rollback instead of rebase?

If you havent done any further updates since the upgrade, the last entry should also be available from grub.

Alternatively to rebase you may need to first uninstall rpmfusion repositories.

I havent tried replacing the packages though, so not sure the best way to do that.

You should be able to rpm-ostree override remove the pipwire main packages and --install in the same command the pulseaudio ones. You probably have to figure out the right combination of packages to pass them in a single command.


rpm-ostree override remove piewire-pulseaudio --install pulseaudio