Updated to Fedora 39, blank screen when booted

I’ve been running Fedora Asahi Remix with GNOME since August on my M2 MacBook Air, and after updating, I only get a blank screen when booting into Fedora.
I noticed that the official remix came out recently, so I decided to update. I ran sudo dnf update and updated my software and got my speakers to work.
I then noticed that I was still running Fedora 38, so I decided to upgrade to 39 by running sudo dnf upgrade --refresh, and then sudo dnf install dnf-plugin-system-upgrade. I tried to run sudo dnf system-upgrade download --releasever=39, but that didn’t work, so I ran sudo dnf system-upgrade download --releasever=39 --allowerasing and with some other flag that involved skipping packages that couldn’t be updated (I don’t remember which flag that was).
I then ran sudo dnf system-upgrade reboot.

After all of that, when I boot into Fedora, I get the Fedora and Asahi logos, and I get the screen with the “OK” symbols, but then I get this screen:

How can I get past this screen and boot successfully? I’ve tried the solutions in the following post, and none of them have worked. It seems the solution here is to update the kernel, so how should I do that?

Apologies for formatting, am writing on mobile.

Did you follow all the announcements we’ve posted since you installed, particularly the kernel-16k and metapackage ones?

Err…nope. I may have installed Asahi after the kernel switch (I don’t remember), but I didn’t install the metapackage and I didn’t pay attention to the other announcements, just tried to update :grimacing:
Does that mean I have to wipe my partition and reinstall?

You could try switching to another TTY with Fn+Ctrl+Option+F2 and seeing if you can log in there or debug it, or try booting with init=/bin/sh from the GRUB menu (press Esc right after the u-boot timeout expires to get into the grub menu, and note that it’s kind of broken and the cursor doesn’t display; it’s a known issue with the u-boot console). If you didn’t install the metapackage you’re missing extra protection from breaking your system, so that --allowerasing might have well been what broke things. It’s not supposed to be necessary if your system doesn’t have any weird or incompatible packages installed.

It sounds like you ran into issues with the upgrade, but then just forced things through without taking note of what the problems were or what actually was preventing a normal upgrade, so it’s anyone’s guess what state your system ended up in without more information :frowning:

Can’t seem to switch into another TTY or get into the GRUB menu, so I think I’ll just wipe the partition and reinstall—seems easier anyway. Not a big deal, didn’t daily drive this partition and I wanted to do something else that involved wiping anyway.

Definitely learned my lesson though—I’ll look over the announcements before updating :slight_smile:

In general we don’t expect to have “action items” like this going forward, it was more of an issue on the way to the official release (which is why it was not official yet, we were still getting all the details ready). The metapackage is actually one major trick that allows us to push fixes and changes to users without manual action. Though please do check for announcements from time to time, in case something comes up. I actually am thinking of developing some trivial “in-system” announcement thing, like Gentoo’s eselect news, so we can pop-up really important stuff for users… hopefully it won’t be necessary, but you never know.

But when you run major version upgrades, always stop and check if the regular process doesn’t work, don’t just override things. It’s better to post your issue here and ask whether it will be a problem, so you can know for sure that your system isn’t going to break.

As for wiping: follow the instructions here: Partitioning cheatsheet · AsahiLinux/docs Wiki · GitHub (you can skip resizing macOS back to full size, since you’re just going to install again into free space).

1 Like