Updated to 36 - MESA-LOADER: failed to open i915 when playing video


I just updated my (15 year old) laptop to Fedora 36 - everything seems to be running fantastically, with exception of below error message when playing video with mpv:

libEGL warning: MESA-LOADER: failed to open i915: /usr/lib64/dri/i915_dri.so: cannot open shared object file: No such file or directory (search paths /usr/lib64/dri, suffix _dri)

Video itself plays okay-ish, but I’m assuming I’m in software rendering mode with possibly related performance issues.

The /usr/lib64/dri directory is indeed missing i915_dir.so as described in the error message - what can I do?


Have you done a search for what provides that file and verified the package is installed?
sudo dnf provides /usr/lib64/dri/i915_dri.so
rpm -qa whatprovides /usr/lib64/dri/i915_dri.so

While I have not tested with a machine of the age you state, and cannot test the video you did not name or link, I do see that there are no i915*.so libraries in that path.

Have you by chance tried any other video players such as totem or vlc?
Have you made certain all the best supporting software such as ffmpeg and gstreamer1* packages are installed from rpmfusion?
This may be a result of not having the best supporting software and not necessarily hardware related.

For those interested:

The video is a locally downloaded mp4 from youtube (via youtube-dl script) on Hudson valley art school - Nature and the American Vision: The Hudson River School | Curator Confidential - YouTube

The same error message comes up with vlc -v and mpv - so this might not be an issue with the player.

Non-free rpmfusion’s enabled, ffmpeg-lib’s installed.
I also did sudo dnf groupupdate Multimedia after update, but it didn’t pull anything.

Discussion here (https://bbs.archlinux.org/viewtopic.php?id=275232) seems to point to the mesa package changing and no longer carrying i915 - and suggests mesa-amber package, but of course that’s for arch. Would something similar apply to Fedora as well?

Also, just in case I wasn’t too clear in the opening post - the system worked without any i915 or codec errors using the same mp4 file and player programs under Fedora 35. The error message only started showing up after 36 update.


This implies it may be a bug against fedora 36. I would suggest, however, that you wait until it is released in the next few days then do a full update once the final release is out just to see if the issue is already solved before you file a bug.

You can also go to bugzilla and search the existing bugs for your particular problem in case it has already been reported.