Local video playback problem F36/37

I’m pulling my hair out here and need help…

Brand new Thinkpad P15v – installed F36 with various codecs, ffmpeg, etc. installed but can’t play local MP4 videos that play fine on Windows and another F36 Thinkpad. I have tried multiple videos. Something is missing. I just upgraded to F37 to see if it would fix the problem, but no…

The Gnome “Videos” video player says “The file you tried to play is an empty file.”
Opening with VLC shows no error message, but there appears to be nothing showing to play.
When adding a video into OpenShot, it says “xxx is not a valid video, audio, or image file.”

Based on various articles online, I have installed:

  • openh264 v2.1.0 → 2 copies showing up as installed in Software (790k and 778.2k)
  • All 8 GStreamer codec packs listed in Gnome “Software”
  • ffmpeg (base, devel and libs)

What else can I do?

1 Like

Oh… and video streaming works from YouTube on Firefox but opening the video files locally via Firefox doesn’t work either (says “No video with supported format and MIME type found.”)

Local MOV, AVI, and WMV files play fine. It just appears to be MP4.

Hi @aguanno , welcome to the community! Please do take a look at the introductory posts in the #start-here category if you’ve not had a chance to do so yet.

The usual way to install all the necessary codecs is here:

That has worked for most in the past.

Can you run file <your file> perhaps to get more info on it?

1 Like

You say you have installed ffmpeg and gstreamer files. Have you installed them from rpmfusion or what.

There are a lot of codecs (both audio and video) that are not supported out of the box on fedora due to licensing, patent, or copyright issues. I believe mp4 is one of those codecs.

The similar packages installed from rpmfusion are capable of supporting most codecs.
The link given by Ankur above leads you to the solution for most codec issues on fedora.

I had a similar issue after updating to F37.
In my case, I had an external HDMI monitor attached to my laptop.
After my first update wtih F37 (I think it was an update of pipewire libraries) all my local video players like VLC, mpv or Gnome Videos were set to use HDMI audio instead of local speakers or headphones.
I solved it by opening a local video with VLC and switch it back to local sound controller through the options in the Menu Bar:

Audio --> Audio Device --> Family 17h/19h HD Audio Controller

And that worked for me.
It was not necessary to change any other settings in the other video players.

1 Like