Update error in updating from fedora 38 to fedora 39


I am getting this error while updating my fedora 38 to fedora 39.
I have updated all my packages multiple times and tried but still got the same error, even with the terminal.
I have one update remaining though, of my firmware which isn’t updating (I’ve tried multiple times).

from a terminal run

sudo dnf repolist

It should list a few repos including fedora-cisco-openh264.

If that is the case then I suggest you you try the upgrade from the terminal.
Following the instructions here: Upgrading Fedora Using DNF System Plugin :: Fedora Docs

If you get errors again you can copy-n-paste the text here as preformatted text
(no screen shots please). Use the </> that is in the edit box icons.

[MIRROR] gstreamer1-plugin-openh264-1.22.1-1.fc39.x86_64.rpm: Interrupted by header callback: Inconsistent server data, reported file Content-Length: 293, repository metadata states file length: 24640 (please report to repository maintainer)
[FAILED] gstreamer1-plugin-openh264-1.22.1-1.fc39.x86_64.rpm: No more mirrors to try - All mirrors were already tried without success

This is the error I’m getting by following the instructions from the fedora docs (link you’ve given).

The openh264 repo is hosted by Cisco for legal reasons. It seems like you might be getting blocked or something. Are you able to download the packages manually from https://codecs.fedoraproject.org/openh264/39/x86_64/os/Packages/ ? Are they the actual rpm packages or 293-byte files? In the latter case, are they text files? What do they contain?

Also, can you confirm that is the URL returned from the metalink?:

curl 'https://mirrors.fedoraproject.org/metalink?repo=fedora-cisco-openh264-39&arch=x86_64'

I’d also mention that the openh264 packages aren’t strictly necessary, but as of F39 they’re required for full codec support (except via Flathub). RPM Fusion’s ffmpeg now has a hard dependency on it for … reasons.

I can’t download the packages manually from that link, it is showing:

The URL you're trying to reach has been blocked!

I didn’t understand the other part, that what URL you are asking from metalink?

That curl command simulates what dnf does to get the list of mirrors to try. It outputs a block of XML that includes one or more <url> elements. You probably don’t need to check that now if you’re getting that error from the URL I provided.

It seems like you might be hitting some kind of firewall? (ISP/government?)

Those downloads ultimately redirect to e.g. http://ciscobinary.openh264.org/openh264-2.3.1-2.fc39.x86_64.rpm

I’m guessing that’s the domain that is blocked.

Oh got it.
Yes maybe I am blocked, I don’t know the reason though.

But I used VPN (Proton VPN) and it didn’t show the block page this time but neither did it download the package, on clicking the package it just loads and nothing happens after loading.