Latest Update failed re openh264 packages not signed!

Update failure

Total                                                                                         3.3 MB/s | 126 MB     00:38
Package gstreamer1-plugin-openh264-1.20.3-1.fc36.x86_64.rpm is not signed
Package mozilla-openh264-2.3.0-1.fc36.x86_64.rpm is not signed
Package openh264-2.3.0-1.fc36.x86_64.rpm is not signed
Error: GPG check FAILED

I was going to post the same thing, and ask the question (consider it asked), “To whom should we report this?”

As a temporary fix, I ran “sudo dnf clean packages”, and then ran “sudo dnf upgrade --refresh --exclude=gstreamer1-plugin-openh264-1.20.3-1.fc36.x86_64.rpm --exclude=mozilla-openh264-2.3.0-1.fc36.x86_64.rpm --exclude = openh264-2.3.0-1.fc36.x86_64.rpm” so that everything else would update.

1 Like

Some work is being done on this: Issue #10938: Please send openh264-2.3.0-1.fc36 and openh264-2.3.0-1.fc37 to Cisco - releng -

A workaround is in place, I believe, and it should fix itself once the updates get to your closest mirror.


For users, the issue is solved: Just do sudo dnf clean all and then sudo dnf update, or directly sudo dnf update --refresh. After that, you can work as usual with sudo dnf update or whatever interface you use for updates. The error should be gone now. The unsigned packages are no longer in the updates, which is not a problem because they are not security/compatibility critical at the moment. Expect that they will be added again when the issue in general is solved. But the users do not need to care about that. Thanks to @kevin for taking care of this!


try sudo dnf clean all and then sudo dnf upgrade --refresh see if that works.


I was getting a similar problem on Silverblue…

$ sudo rpm-ostree upgrade
error: importing RPMs: package gstreamer1-plugin-openh264-1.20.3-1.fc36.x86_64 cannot be verified and repo fedora-cisco-openh264 is GPG enabled: /var/cache/rpm-ostree/repomd/fedora-cisco-openh264-36-x86_64/packages/gstreamer1-plugin-openh264-1.20.3-1.fc36.x86_64.rpm could not be verified.

Since dnf is not installed on ostree systems like Silverblue/Kinoite, sudo dnf clean all did not work.

However, sudo rpm-ostree cleanup --repomd did work for me (it doesn’t output anything, but the next sudo rpm-ostree worked normally).