Unreadable Colors in popups on Gnome Desktop

I’m running Gnome 40 in classic mode on Fedora 34. I use a number of extensions to get the look/feel of older versions of the interface and generally it works well for me. A recent update changed the colors of several of the UI elements making them a lot harder to read and I can’t figure out where the colors are controlled. I’ve scrounged around in Tweaktool and dconf editor to no avail.

The two in particular that I’m having trouble with are:

  • The workspace names that pop up when you hover over the workspace switcher on the right side of the bottom bar.

  • The large speaker icon that pops up in the center of the screen when you adjust the volume.

Both of these appear as white text on a light-gray background and are very difficult to read. (I’ve taken screenshots to demonstrate, but this forum doesn’t seem to allow attachments).

Any suggestions on how to make these clearer?

1 Like

Screenshot is allowed make sure you haven’t blocked JavaScript and sometimes some browser extension blocks the feature to upload you can try disable those and try to reload and upload them.
Give us some system info
inxi -Fzx
List out extensions also
gnome-extensions show
Make a gnome-extensions reset

1 Like

I would say if you have a theme where is not default (installed on your own), check if there is an update of it. Otherwise try an other theme.

I already had a similar problem just with the mate desktop. To find the issue is most more difficult than to find a theme who fits your needs.

1 Like

+1, the simplest way to check if it is a theme related issue is to create a new user and see if the issues persist. If they do not under these “vanilla” configurations/conditions, it’s an issue with the user-specific theme configuration.

1 Like

[requested info in formatted text below]

Note: ‘gnome-extensions reset’ requires providing a UUID for each extension so that wasn’t practical to do. I have recently removed and reinstalled all the extensions though and that hasn’t helped this situation.

I’ll upload screenshots in a separate reply due to new user limits.



With regard to themes - I’m using the default Adwaita theme and have not installed any others. I’ve tried switching to other provided themes and doing so does not affect the colors of these popups.

Put in in a </> mode all output
Make your system up to date sudo dnf update and then reboot as there is a kernel update.

inxi -Fzx
  Kernel: 5.16.14-100.fc34.x86_64 x86_64 bits: 64 compiler: gcc
    v: 2.35.2-6.fc34 Desktop: GNOME 40.9
    Distro: Fedora release 34 (Thirty Four)
  Type: Desktop Mobo: ASRock model: Z77 Extreme6/TB4
    serial: <superuser required> BIOS: American Megatrends v: P1.30
    date: 10/19/2012
  Info: quad core model: Intel Core i5-3570K bits: 64 type: MCP
    arch: Ivy Bridge rev: 9 cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 2850 high: 3373 min/max: 1600/3800 cores: 1: 2661
    2: 2429 3: 2937 4: 3373 bogomips: 27200
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel IvyBridge GT2 [HD Graphics 4000] vendor: ASRock
    driver: i915 v: kernel bus-ID: 00:02.0
  Display: x11 server: X.Org v: 1.20.14 driver: X: loaded: modesetting
    unloaded: fbdev,vesa gpu: i915 resolution: 1680x1050~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2)
    v: 4.2 Mesa 21.1.8 direct render: Yes
  Device-1: Intel 7 Series/C216 Family High Definition Audio
    vendor: ASRock Z77 Extreme4 driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
  Device-2: Philips s SAA7131/SAA7133/SAA7135 Video Broadcast Decoder
    vendor: KWorld ATSC 110 Digital driver: saa7134 v: 0, 2, 17 bus-ID: 3a:01.0
  Device-3: Texas Instruments PCM2902C Audio CODEC type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-2.3:4
  Sound Server-1: ALSA v: k5.16.14-100.fc34.x86_64 running: yes
  Sound Server-2: JACK v: 1.9.17 running: no
  Sound Server-3: PulseAudio v: 14.2-rebootstrapped running: no
  Sound Server-4: PipeWire v: 0.3.40 running: yes
  Device-1: Broadcom NetLink BCM57781 Gigabit Ethernet PCIe
    vendor: ASRock Z77 Extreme4 driver: tg3 v: kernel port: N/A bus-ID: 33:00.0
  IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  Local Storage: total: 1.82 TiB used: 1.07 TiB (59.1%)
  ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB
  ID-2: /dev/sdb vendor: Western Digital model: WD10EFRX-68FYTN0
    size: 931.51 GiB
  ID-1: / size: 49.09 GiB used: 32.28 GiB (65.7%) fs: ext4 dev: /dev/dm-1
    mapped: fedora_lynnie-root
  ID-2: /boot size: 476.2 MiB used: 221.1 MiB (46.4%) fs: ext4
    dev: /dev/sda1
  ID-3: /home size: 662.39 GiB used: 345.97 GiB (52.2%) fs: ext4
    dev: /dev/dm-2 mapped: fedora_lynnie-home
  ID-4: /opt size: 196.74 GiB used: 148.47 GiB (75.5%) fs: ext4
    dev: /dev/dm-3 mapped: fedora_lynnie-opt
  ID-1: swap-1 type: partition size: 7.87 GiB used: 0 KiB (0.0%)
    dev: /dev/dm-0 mapped: fedora_lynnie-swap
  ID-2: swap-2 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 36.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 304 Uptime: 1h 8m Memory: 23.17 GiB used: 4.2 GiB (18.1%)
  Init: systemd runlevel: 5 Compilers: gcc: 11.2.1 clang: 12.0.1 Packages: 2
  note: see --pkg Shell: Bash v: 5.1.0 inxi: 3.3.13

$ gnome-extensions list

I just did an update before adding these replies

You have lots of extensions so it is really hard to understand which one get out of sync or having inconsistency.
Try with 1 that create a new user.
And switch to that and see if that user also have those issues or not. And be sure your system is uptodate
Edit- you can add user with useradd commend or go to settings and user option and add user and add a user and switch to it
Else sudo useradd name

I have created a new user with the default extensions and theme as Ankur Sinha and martin luther suggested. The color issues persist in that situation.

It is interesting to note that when I log in with the pure “Gnome” desktop (not “Gnome Classic”) that the color of the sound volume popup becomes a white icon on a dark gray background.

Themes often have a dark and a light version. It seams that you have a light version and the icon for dark. This means it should be inverted.

Please check what themes you have installed and maybe you find a alternative. You can do this with:
sudo dnf info *theme*

Yes, I’ve tried both Adwaita and Adwaita Dark themes. Neither one seems to affect the appearance of these popups, and although I’ve got a few other pre-installed themes they also don’t affect the shading. The only time I’ve seen these popups change color is when selecting between standard Gnome and Gnome Classic operating modes.