Uninstalling VMware player 16.1.2


I am in need of some assistance here and I hope that I can get you smart guys help. Very long story short I installed VMware player 16.1.2 to run Cisco ISE. After many hours of troubleshooting I found the reason I can’t get ISE to install on 16.1.2 is because I’m using older processors. I have two AMD Opteron 6128 processors with 8 cores each and the machine is running with 48GB of RAM. It’s funny that F34 is reading 50.6GB.

This is my problem. I have tried to uninstall VMware by CLI and it said it did but it is still installed on the machine. I’ve restarted the system and tried a few more time to uninstall it but it won’t. I tried to install version 15.5.2 but it won’t since 16.1.2 is still on the machine.

Here is the output I’m receiving when I try to reinstall/uninstall VMware player
[sam@fedora Downloads]$ sudo sh VMware-Player-16.1.2-17966106.x86_64.bundle
[sudo] password for sam:
Extracting VMware Installer…done.
Uninstalling VMware Player Application 16.1.2[sam@fedora Downloads]$
[sam@fedora Downloads]$ sudo sh VMware-Player-16.1.2-17966106.x86_64.bundle
Extracting VMware Installer…done.
Uninstalling VMware Player Application 16.1.2[sam@fedora Downloads]$
[sam@fedora Downloads]$ sudo vmware-installer -u vmware-player
vmware-player is not an installed product.
Available products are:

[sam@fedora Downloads]$

Since I’m new to this any information to help me remove this would be very helpful.

Where do you see it is still installed and where is the output from where you try to install the older version?


Hello Dalto,

I see it when I select “Show Applications”. I’m able to open it and actually run it. The output is different from yesterday but it may be because I tried to uninstall VIX 1.17.

[sam@fedora VMware 15]$ sudo su VMware-Player-15.5.2-15785246.x86_64.bundle
[sudo] password for sam:
su: user VMware-Player-15.5.2-15785246.x86_64.bundle does not exist or the user entry does not contain all the required fields

It should be

sudo VMware-Player-15.5.2-15785246.x86_64.bundle

You have an extra su in there.

I tried that and this is the result.

[sam@fedora Downloads]$ sudo VMware-Player-15.5.2-15785246.x86_64.bundle
[sudo] password for sam:
sudo: VMware-Player-15.5.2-15785246.x86_64.bundle: command not found

You need to make it executable.

chmod a+x VMware-Player-15.5.2-15785246.x86_64.bundle

Thank you but that did not work. Here is the output after running chmod.

[sam@fedora VMware 15]$ sudo sh VMware-Player-15.5.2-15785246.x86_64.bundle
Extracting VMware Installer…done.
/usr/lib/vmware-installer/3.0.0/vmis-launcher: error while loading shared libraries: libpython3.8.so.1.0: cannot open shared object file: No such file or directory
[sam@fedora VMware 15]$ ls

sudo dnf provides \*/libpython3.8.so.1.0
sudo dnf install python3.8

Is that version compatible with the version of Fedora you are running?

Here is the output for the cmds provided.

[sam@fedora Downloads]$ sudo dnf provides */libpython3.8.so.1.0
Last metadata expiration check: 4:16:07 ago on Tue 10 Aug 2021 02:32:15 PM EDT.
python3.8-3.8.8-1.fc34.i686 : Version 3.8 of the Python interpreter
Repo : fedora
Matched from:
Filename : /usr/lib/libpython3.8.so.1.0

python3.8-3.8.8-1.fc34.x86_64 : Version 3.8 of the Python interpreter
Repo : fedora
Matched from:
Filename : /usr/lib64/libpython3.8.so.1.0

python3.8-3.8.11-1.fc34.i686 : Version 3.8 of the Python interpreter
Repo : updates
Matched from:
Filename : /usr/lib/libpython3.8.so.1.0

python3.8-3.8.11-1.fc34.x86_64 : Version 3.8 of the Python interpreter
Repo : updates
Matched from:
Filename : /usr/lib64/libpython3.8.so.1.0

[sam@fedora Downloads]$ sudo dnf install python3.8
Last metadata expiration check: 4:16:41 ago on Tue 10 Aug 2021 02:32:15 PM EDT.
Dependencies resolved.

Package Architecture Version Repository Size

python3.8 x86_64 3.8.11-1.fc34 updates 16 M

Transaction Summary

Install 1 Package

Total download size: 16 M
Installed size: 107 M
Is this ok [Y/n]:
Downloading Packages:
python3.8-3.8.11-1.fc34.x86_64.rpm 7.9 MB/s | 16 MB 00:01

Total 7.2 MB/s | 16 MB 00:02
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
Preparing : 1/1
Installing : python3.8-3.8.11-1.fc34.x86_64 1/1
Running scriptlet: python3.8-3.8.11-1.fc34.x86_64 1/1
Verifying : python3.8-3.8.11-1.fc34.x86_64 1/1



1 Like

I can’t say either way. I now know that my hardware is to old for it.

According to the documentation, version 15.5 supports up to Fedora 32. That doesn’t mean it definitely won’t work but it might not.

Do you need vmware specifically or could you use a different virtualization software? If it is the latter, you might try gnome boxes.

1 Like

I’m using VMware in concert with GNS3. So I need it.

This is what I received when I tried to install 15.5.2.

sam@fedora VMware 15]$ sudo sh VMware-Player-15.5.2-15785246.x86_64.bundle
Extracting VMware Installer…done.
Traceback (most recent call last):
File “/usr/lib/vmware-installer/3.0.0/vmware-installer.py”, line 19, in
from vmis.core.common import SYSTEM_BOOTSTRAP, SYSTEM_DATABASE, ParseExceptionTuple
File “/usr/lib/vmware-installer/3.0.0/vmis/core/common.py”, line 14, in
from vmis.core import install
File “/usr/lib/vmware-installer/3.0.0/vmis/core/install.py”, line 16, in
from vmis.core.component import ComponentError, ComponentTypes
File “/usr/lib/vmware-installer/3.0.0/vmis/core/component.py”, line 14, in
from gzip import GzipFile
File “/usr/lib/vmware-installer/3.0.0/python/lib/gzip.py”, line 9, in
import zlib
ModuleNotFoundError: No module named ‘zlib’

It looks like gns3 has virtualbox images as well.


virtualbox would likely be easier to install.

1 Like

Actually, I’ve tested that image in GNOME Boxes, and it works just fine.

1 Like

Here is an update to this issue.

As I am new to Fedora I did a clean install to F34 with KDE Plasma Desktop. Why? I got tired of trying to fix something I just don’t understand how it works. After the install I ran the recommended dnf updates etc… I then visited VMware to download versions 15.5.2, 15.5.7, 16.0.0, and 16.1.2. All versions install without issue, I installed one and removed it before installing another, and this is where things changed a little. For the 15.5.x versions again the installation worked without an issue but they will not open. I can see them start but after 3 to 4 seconds they close.

For version 16.0.0 and 16.1.2 it won’t complete the installation because it is looking for kernel 5.11.12 and I have kernel 5.13.8. I’m not sure how to have VMware use the new kernel but this is where I’m stuck. I would put up a screen capture but I haven’t figured out how to do that just yet.

Again, all recommendation are welcome including wiping this machine and starting back over.
As a reminder this is the hardware I installed in this machine.
2 AMD Opteron 6128 processors with 8 cores each
48GB of RAM

By the way. Thank Dalto for your suggestion of using something different. However, moving to Linux and trying something else new at the same time is not something I want to do as Fedora is causing me to lose sleep trying to get VMware and GNS3 to work.

I run VMware Workstation on Fedora all day, every day. I can tell you from experience that doing so requires ongoing maintenance. Every time there is a kernel update, you need to rebuild the modules. Sometimes kernel updates break VMware and you either have to hold back the kernel or find patches and integrate them yourself.

Sometimes, VMware will stop using the bundled libs and start using system libs requiring you to make ldconfig changes.

While none of these are impossible tasks, given the nature of the questions you have and the mistakes you are making I think it would be much easier for you to learn Gnome Boxes or Virtualbox than learning to keep a VMware install running long-term.

Virtualbox and Gnome Boxes both “Just work” and the learning curve is fairly low.

That being said, I prefer VMware and use it myself. However, keeping it running requires some experience working with your system and it is pretty far from hassle free.

1 Like

So in the nicest way possible. Learn how to crawl before learning how to stand. LOL Ok. I will find Virtualbox, as GNS3 says it works with it, and will see what happens from there.

I will keep you posted on my painful progression. lol

Thank you.