Unable to set up proxy

I committed to fedora. Formatted it on my main partition and transferred all my PC usage to it, after about a decade of Ubuntu as a secondary OS.

Everything went great. Lost a lot of compatibility, switched many eco systems, it was a different, rougher digital life, but braving it was nice and doable. untill…

in my area there is a monopoly on home internet by a single company. I finally terminated my service with them recently and am using my phone as a hotspot as my main and only internet source.

cell carriers limit hotspot tethering speeds to 0.6 Mb/s. when I use special apps like PdaNet, I get my full speed of up to 20Mb/s.
PdaNet and similar apps require you to install an app on the connecting device(android or windows), or setup proxy, otherwise they won’t work.

setting up proxy on linux works only for web browsers, not steam, not system update, not even to update the clock. there is no universal proxy setting for linux like there is for windows.

VPN didn’t work.

following the various universal proxy settings for fedora didn’t work.

Trying other android apps that unlimit your tether didn’t work.

trying some rando’s home made app(can’t even call it that) for pdanet on linux didn’t work.

I’ve been struggling with this for months. goot good help from the Fedora telegram group but my issue got swollowed quickly.

Maybe Fedora was too much for me to handle and I shoould’ve just stuck with Ubuntu. They sacrifice their open source ethos but at least their OS is functional on laymen’s computers(I think?)

I’m breathing my last fedora breaths. considering buying a windows license. at least then I get to say I’ve tried Linux as primary PC and didn’t work… :frowning:

The issue you are experiencing is somewhat unclear. Can you try to explain the problem another way?

1 Like

I cannot connect the entirety of my Fedora PC to the internet, because my internet connection requires a proxy setup.

Maybe there’s a solution on your phone instead of in Fedora? If your phone/carrier is limiting the hotspot connection, you might want to look there.

I found this article that might be useful if you have an Android Phone.

1 Like

And what is this ?


That’s not quite true. Can you please tell us specifics of what you’ve tried, and what your installation is? Is it Fedora 35 or 36? What desktop environment is this?

On Fedora 36 Workstation/Gnome, network settings have a network proxy set up that will work for the full system:

Can you tell us what you tried to set this up please? Is there some documentation on what your internet connection requires? Does it work with Windows and/or another OS? For example can you use it to run a second phone? (this is for us to see if this is a Fedora Linux issue or something on the phone side of things)

We need more information to help you with this, so that’ll be a start.

1 Like

Hey Kevin, good point, I looked there too; I’ve tried every other app that unlimits my tethering speed, and they all work in a similar fashion:
1- you install an app on your phone, which creates a special hotspot.
2- you either install another app on the connecting device(android apple or windows)
3- Alternatively to 2, you can setup proxy settings.

the first part of that article is wrong:

setting proxy settings in the Desktop UI apply only to web browsers, but nothing else on the system:

  • software updates don’t detect an internet connection
  • steam doesn’t detect an internet connection
  • even the wifi icon in the upper right corner of the screen displays a question mark, instead of the solid wifi sign that it is connected to the internet (even though browsers connect fine)

The second part is not lucid enough to follow. I still did apply the steps it lists to the best of my ability and still no internet connection.

1 Like

Thanks Ankur.

I tried way too many things, so not sure how to trace back and list a clean set of steps I took.
I used Fedora35 with the standard environment it ships in. I see fedora 36 is released, I might download that from a different computer and upgrade my system with a flash drive or something, then take simple steps and post screenshots here, of how adding proxy settings to the desktop interface does not get recognized throughout the whole system.

1 Like