Unable to rebase from fedora rawhide kionite to fedora silverblue

These are the steps in chronological order that I am following -

  1. Check status of branches present locally -
rpm-ostree status
State: idle
                  Version: 38.20230724.0 (2023-07-24T00:47:54Z)
                   Commit: 536e6f48f3b1ce98b250ec8247e6d8947dd256e8d8fc738092f8b313114787f2
             GPGSignature: Valid signature by 6A51BBABBA3D5467B6171221809A8D7CEB10B464
                     Diff: 14 upgraded, 764 downgraded, 463 removed, 182 added

● fedora:fedora/rawhide/x86_64/kinoite
                  Version: Rawhide.20230724.n.0 (2023-07-24T05:53:03Z)
                   Commit: 5e35fdb0903c4d357c15b05eeb14420849f933936b43769bcfd4e499ed1cdbb3
             GPGSignature: Valid signature by E8F23996F23218640CB44CBE75CF5AC418B8E74C
  1. Upgrade everything in kinoite
rpm-ostree upgrade
Receiving metadata objects: 1/(estimating) 24 bytes/s 196 bytes...                                                                                                  
2 metadata, 0 content objects fetched; 788 B transferred in 9 seconds; 0 bytes content written
Receiving metadata objects: 1/(estimating) 24 bytes/s 196 bytes... done
No upgrade available.

  1. Rebase to silverblue
rpm-ostree rebase fedora:fedora/38/x86_64/silverblue
error: Old and new refs are equal: fedora:fedora/38/x86_64/silverblue

Problems -

  1. What does the error exactly mean?I know how git works but there’s some kind of mental block which is not letting me understand what the error is supposed to mean. On the surface it looks very straight forward.
  2. How to do switch to silverblue:stable from kinoite:rawhide?
  3. And then ultimately, I want to switch to ublue base image. The documentation for that looks pretty straight forward but if you guys have any tips then let me know.

Please let me know if there are any logs that I can provide or anything else in general. I am trying different things currently so I’ll update this post every time I hit a new roadblock or achieve success.

Thank you Ladies and Gentlemen for reading this question(a bunch of questions?).

Edit - Uum. My computer crashed and fixed itself(?). I don’t know what’s happening anymore. Do computers really run on magic smoke? Man that’s weird. Anyways, here’s what happened. I updated my system as usual. I saw that thunderbird got 116 release (which is by the way a major deal so check it out). So I opened thunderbird and I was greeted with the good old welcome screen of black death and unresponsive system. So after waiting for 10 minutes, I just hard booted my laptop (Thinkpad T14 Gen3 AMD custom) and after booting my laptop, the GRUB screen was entirely skipped and I was greeted with sddm (that’s what gnome uses right?). Anyways, thanks for the thunderbird guys for helping me fix my computer but I think they need a little help to make thunderbird a teeny tiny more stable. I’ll start contributing towards that as soon as I can because that’s what we do right? We make stuff, we break stuff, we make it better the second time! Thanks for reading.


Edit 2 -


So yeah uum, after rebooting I was stuck in emergency mode. I tried a lot of things but nothing worked. I don’t even have any other machine so I was reading everything on my phone. Somehow managed to find a machine and flashed silverblue ISO. I tried to recover the data but the installation media (anaconda I presume?) was hell bent on wiping everything (there’s a lot of things in between so don’t take it literally.) So all in all, I lost all my data (yeah I know, I should have kept a backup) and had to hunt down a machine to fix my laptop. But no issues. This ain’t my first rodeo.


It looks like you just need to reboot into silverblue?

I think what’s going on is: you have fedora silverblue ready, you just need to reboot and it will put you into silverblue.

When you ran rpm-ostree rebase fedora:fedora/38/x86_64/silverblue It already had fedora silverblue deployed, see:

The deployment that you are in, currently is the one that has this symbol ●

So all you have to do is reboot and enjoy silverblue!

Regarding Ublue, you may want to make your own image. It’s not that hard, see: https://universal-blue.org/tinker/make-your-own/

I am sorry I forgot to add what happens when I reboot. I see GRUB and when I select silverblue I am thrown into the emergency mode where I get only three options. I am attaching a photo since I couldn’t really take a screenshot. Sorry for the bad image quality.

Please check the reply I gave to @castrojo

Hello @surajmishra , If you have a solution, even a puzzling one, could you please mark the correct comment where the solution is explained, as the solution? That way, this get’s closed as it really has no need to continue after solution.

Hello @jakfrost, thank you for bringing this to my attention. Unfortunately I was stuck in emergency mode so couldn’t update the post. I had to nuke everything. Should I create a new comment and ask people to refer to the second edit to my post? And mark that comment as an answer?

No, it’s alright. I can close it without a solution marked and I feel like you ended up in a spot that was not a solution to your original problem. So the trail may not be helpful for most.