[Silverblue] Error: Unable to rebase to F37

Error (full output below):

(rpm-ostree rebase:26366): GLib-GIO-WARNING **: 13:21:53.241: _g_dbus_worker_do_read_cb: error determining bytes needed: Blob indicates that message exceeds maximum message length (128MiB)

System Info

$ sudo dmidecode -t system
# dmidecode 3.3
Getting SMBIOS data from sysfs.
SMBIOS 3.2.0 present.

Handle 0x0001, DMI type 1, 27 bytes
System Information
	Manufacturer: LENOVO
	Product Name: 82B1
	Version: Lenovo Legion 5 15ARH05H
	Serial Number: PF2V630W
	UUID: 03aa0103-7fdb-11eb-80ec-38f3ab156725
	Wake-up Type: Power Switch
	SKU Number: LENOVO_MT_82B1_BU_idea_FM_Legion 5 15ARH05H
	Family: Legion 5 15ARH05H

Handle 0x0020, DMI type 12, 5 bytes
System Configuration Options
	Option 1: String1 for Type12 Equipment Manufacturer
	Option 2: String2 for Type12 Equipment Manufacturer
	Option 3: String3 for Type12 Equipment Manufacturer
	Option 4: String4 for Type12 Equipment Manufacturer

Handle 0x0030, DMI type 32, 20 bytes
System Boot Information
	Status: No errors detected

When i tried to rebase I got this error

$ rpm-ostree rebase fedora:fedora/37/x86_64/silverblue --uninstall rpmfusion-free-release-36-1.noarch --uninstall rpmfusion-nonfree-release-36-1.noarch --install https://mirrors.rpmfusion.org/free/fedora/rpmfusion-free-release-37.noarch.rpm --install https://mirrors.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-37.noarch.rpm
Downloading https://mirrors.rpmfusion.org/free/fedora/rpmfusion-free-release-37.noarch.rpm...done
Downloading https://mirrors.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-37.noarch.rpm...done
⠤ Receiving metadata objects: 1/(estimating) 39 bytes/s 196 bytes                                                                                                                                                                              2 metadata, 0 content objects fetched; 788 B transferred in 7 seconds; 0 bytes content written
Receiving metadata objects: 1/(estimating) 39 bytes/s 196 bytes... done
Checking out tree 2a98f17... done
Enabled rpm-md repositories: fedora-cisco-openh264 rpmfusion-free-updates rpmfusion-free rpmfusion-nonfree-updates rpmfusion-nonfree phracek-PyCharm fedora-modular updates-modular updates fedora google-chrome tailscale-stable copr:copr.fedorainfracloud.org:petrb:xboxdrv copr:copr.fedorainfracloud.org:atim:starship updates-archive
Importing rpm-md... done
rpm-md repo 'fedora-cisco-openh264' (cached); generated: 2022-10-06T11:01:40Z solvables: 4
rpm-md repo 'rpmfusion-free-updates' (cached); generated: 2022-08-11T18:15:25Z solvables: 0
rpm-md repo 'rpmfusion-free' (cached); generated: 2022-11-11T16:54:42Z solvables: 496
rpm-md repo 'rpmfusion-nonfree-updates' (cached); generated: 2022-08-11T18:17:58Z solvables: 0
rpm-md repo 'rpmfusion-nonfree' (cached); generated: 2022-11-11T17:25:12Z solvables: 218
rpm-md repo 'phracek-PyCharm' (cached); generated: 2022-10-16T04:25:30Z solvables: 5
rpm-md repo 'fedora-modular' (cached); generated: 2022-11-10T09:23:24Z solvables: 1454
rpm-md repo 'updates-modular' (cached); generated: 2022-11-10T20:30:33Z solvables: 1454
rpm-md repo 'updates' (cached); generated: 2022-11-15T01:10:34Z solvables: 6944
rpm-md repo 'fedora' (cached); generated: 2022-11-10T09:30:00Z solvables: 66822
rpm-md repo 'google-chrome' (cached); generated: 2022-11-10T21:11:09Z solvables: 3
rpm-md repo 'tailscale-stable' (cached); generated: 2022-11-10T19:10:51Z solvables: 63
rpm-md repo 'copr:copr.fedorainfracloud.org:petrb:xboxdrv' (cached); generated: 2022-05-10T11:53:29Z solvables: 2
rpm-md repo 'copr:copr.fedorainfracloud.org:atim:starship' (cached); generated: 2022-10-16T03:43:22Z solvables: 2
rpm-md repo 'updates-archive' (cached); generated: 2022-11-15T01:30:00Z solvables: 5181
Resolving dependencies... done

(rpm-ostree rebase:26366): GLib-GIO-WARNING **: 13:21:53.241: _g_dbus_worker_do_read_cb: error determining bytes needed: Blob indicates that message exceeds maximum message length (128MiB)

Here you can follow the official report if you have info/wants to help, Thanks.

Any of you knows how to rebase, bypassing this?

Instead of installing the hard-coded versions from a URL, install the rpm-release from the repos themselves and then the rebase will go smoothly. You want the rpmfusion-release to come from the repos and not just a specific hard-coded release version.

Here’s how I fixed this on my Kinoite box:

sudo rpm-ostree update             --uninstall rpmfusion-free-release-36-1.noarch             --uninstall rpmfusion-nonfree-release-36-1.noarch             --install rpmfusion-free-release             --install rpmfusion-nonfree-release

After doing that, the rebase should work.

1 Like

too late… thanks anyway :wink:

I’ll set it up like that now for the future

my workaround was:

  • rpm-ostree reset
  • reboot
  • rebase
    • rpm-ostree rebase fedora:fedora/37/x86_64/silverblue
  • reboot
  • redo everything (override, install, etc)
    • rpm-ostree override remove firefox firefox-langpacks gnome-software gnome-software-rpm-ostree
    • rpm-ostree install https://mirrors.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://mirrors.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm
    • rpm-ostree install xboxdrv terminator starship android-tools akmod-nvidia xorg-x11-drv-nvidia steam-devices gnome-tweaks inotify-tools

now is clean, thanks

rpm-ostree status 
State: idle
Deployments:
● fedora:fedora/37/x86_64/silverblue
                  Version: 37.20221115.0 (2022-11-15T00:43:51Z)
               BaseCommit: 2a98f17a0c61f2c8c51e4c2228986ade737bbe00725d6932327412f69c671ffd
             GPGSignature: Valid signature by ACB5EE4E831C74BB7C168D27F55AD3FB5323552A
      RemovedBasePackages: firefox firefox-langpacks 106.0.4-1.fc37 gnome-software gnome-software-rpm-ostree 43.1-1.fc37
          LayeredPackages: akmod-nvidia android-tools gnome-tweaks inotify-tools rpmfusion-free-release rpmfusion-nonfree-release starship steam-devices terminator xboxdrv xorg-x11-drv-nvidia

  fedora:fedora/37/x86_64/silverblue
                  Version: 37.20221115.0 (2022-11-15T00:43:51Z)
               BaseCommit: 2a98f17a0c61f2c8c51e4c2228986ade737bbe00725d6932327412f69c671ffd
             GPGSignature: Valid signature by ACB5EE4E831C74BB7C168D27F55AD3FB5323552A
      RemovedBasePackages: firefox firefox-langpacks 106.0.4-1.fc37 gnome-software gnome-software-rpm-ostree 43.1-1.fc37
          LayeredPackages: akmod-nvidia android-tools gnome-tweaks inotify-tools starship steam-devices terminator xboxdrv xorg-x11-drv-nvidia
            LocalPackages: rpmfusion-free-release-37-1.noarch rpmfusion-nonfree-release-37-1.noarch

I get the same error as OP bu I do not have installed rpmfusion, so the proposed fix wouldn’t be useful in my case. Any other advice I might use to be able to update? Thanks.

then do not install rpmfusion repo

just do:

  • backup repo files in case you forget one you need (/etc/yum.repos.d)
  • backup the output of rpm-ostree status that way you know what packages you had layered
  • rpm-ostree reset
  • rpm-ostree rebase fedora:fedora/37/x86_64/silverblue
  • read the backup of rpm-ostree status and install everything back you had layered
    • rpm-ostree install <package1> <package2> <package3>... <packageN>

So some layered package might be making it impossible to rebase to the new version? I understand that Silverblue and ostree variants are just starting, but one of the main selling points is the easy upgrades and I think this should not happen… I hope it can be fixed soon for other people.

I will try to remove every layered package, rebase, and then install them again, and let’s hope I don’t have to do that every Fedora release.

Thanks a lot!

It depends on how you install the packages. If you install a standalone RPM from a URL (ie, RPMFusion in the OP) instead of installing it without a specific version/URL so that it pulls from a repo, then it should be auto-magic.

So, setting up some repo and running rpm-ostree install vlc is better than rpm-ostree install https://some-repo-site/vlc.f36.rpm. The former should work through rebase, but the latter may cause issues.

1 Like

in my case the error doesn’t has to do with the local package (rpmfusion)

It is another issue

Answering your question, if you have the same error message and nobody helps trying to solve it it will remain and yes if it happens again to you the only workaround is to reset the deployment every rebase.


About what @vwbusguy said, is correct. I followed the instructions from RPM Fusion’s website but they are not right and they force you to define them everytime with --uninstall and --install every rebase. The right way to install the rpmfusion repo is rpm-ostree install rpmfusion-free-release rpmfusion-nonfree-release as @vwbusguy wrote above.


About the issue I have, I did changed and removed the local packages and installed RPM Fusion repos as Layered Packages and the problem persisted.

As I said, for you and everyone who reads later. If you have the same error ( (rpm-ostree rebase:26366): GLib-GIO-WARNING **: 13:21:53.241: _g_dbus_worker_do_read_cb: error determining bytes needed: Blob indicates that message exceeds maximum message length (128MiB)) come to github ([Fedora Silverblue] Rebase from F36 to F37 stops on error and hangs ( _g_dbus_worker_do_read_cb) · Issue #4150 · coreos/rpm-ostree · GitHub) and help trying to fix with providing info.

1 Like

Interesting. The step I posted is what allowed me to rebase to Fedora 37 without issue on Kinoite and I have a pretty substantial list of added packages in my overlay. That glib warning itself doesn’t give an indication of the error itself, but that something generated a massive message, which could mean a pretty gnarly coredump or something. In other words, it’s a symptom of the problem but not the problem itself.

I know that a warning shouldn’t be the cause, but that warning is the only message you get and then it hangs.
you can try pressing ctrl+c and you won’t have the terminal back unless you restart the rpm-ostreed service or close the terminal if it is a window. The process does not keeps runnig because I checked and also I let the terminal open for hours just in case.

you can see here the issue isn’t new and like you said looks like the message is a symptom

https://discussion.fedoraproject.org/t/rpm-ostree-update-not-working-anymore/75751