Unable to compose a custom ostree from default repository

Hi guys, I’m trying to create a custom ostree from https://pagure.io/workstation-ostree-config in order to have xfce installed by default.
I followed this article but instead of docker I used a toolbox and instead of SimpleHTTPServer I used http.server.
Currently I’m having two different problems, if I compose using the f32 branch i get the following error:
“error: Updating rpm-md repo ‘fedora-32’: cannot update repo ‘fedora-32’:
Cannot prepare internal mirrorlist:
Status code: 404 for https://mirrors.fedoraproject.org/metalink?repo=32&arch=x86_64 (IP: 209.132.190.2);
Last error: Status code: 404 for https://mirrors.fedoraproject.org/metalink?repo=32&arch=x86_64 (IP: 185.141.165.254)”

Whereas if I compose from rawhide I get this error:
“error: importing RPMs: creating importer: Failed to open /proc/self/fd/58”

I’m pretty much lost at this point, do you have any idea what the problem could be?

I don’t know if it’s useful but I’m building from a Silverblue installation in a virtual machine.

Hello @psiquo,
Welcome to the Fedora community discussion forum.

Have you checked out @Siosm 's versions of Silverblue yet? Here is the link
https://discussion.fedoraproject.org/search?q=silverblue%20kde
Good luck!

Thank you very much for your time and for the answer!
I successfully rebased from kinoite remote but still no luck in composing my own tree from that repo. Thing is I didn’t want to depend on a fork of the project.

I know this is more a quirk of mine instead of an actual problem but I’m very interested in the project and in the ostree concept, hence why I wanted to try and compose my own tree in order to fully comprehend the inner workings (I read the documentation but I’m no expert in the field and didn’t see references to the mentioned errors so I asked here).

Well, aside from the convenience of using the already existing, I was pointing you in that direction to discuss with @Siosm what it is you’re trying to do. He has been helpful with others wanting to do the same thing as you, custom commit of Silverblue.

Oh, sorry I didn’t understand that. 'lll wait for @Siosm to answer.
Thank you very much

Hey @psiquo! As @jakfrost said I am building an XFCE version of Silverblue if you want to try it out. Of course you can also build your own from fedora-xfce.yaml with the following instructions. Let me know if packages are missing or if you encounter any other issue.

Regarding your issues:

  • I used to get 404 with mirrors sometimes too thus I now build with an hard-coded mirror URL in the repo files instead to make it simpler.
  • Make sure that you have enough space especially in /var/tmp as the temporary root directory is stored there during the build. You may have to remove previous incomplete builds manually from there.
  • Stop sssd.service & sssd-kcm.socket before building to avoid issues.
3 Likes

It worked!
Sorry for the late response but I’ve been caught up with work so I couldn’t try again.
I’ve done as you said for the mirrors and it worked perfectly, in the end I built the in the Os and not in a toolbox and the first error disappeared.
Thank you very much @Siosm

2 Likes

The problem with the 404 seems to be about mirrorlist missing fedora-:

diff --git a/fedora-32.repo b/fedora-32.repo
index d2893e8..09004fb 100644
--- a/fedora-32.repo
+++ b/fedora-32.repo
@@ -1,6 +1,6 @@
 [fedora-32]
 name=Fedora 32 $basearch
-mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=32&arch=$basearch
+mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=fedora-32&arch=$basearch
 enabled=0
 gpgcheck=1
 metadata_expire=1d

I have added that and can compose with no issues.

BTW thanks a million for your instructions!

2 Likes

Good catch! I will make a PR!

1 Like