Unable to browse/upload file F39

When on a web page and trying to upload/select a file (as in a backup/restore function or to select a file for upload) the file selection window does not appear.
First noticed when attempting to restore a router/firewall configuration by using a backup file. Also not working on other systems and public Websites.

File uploads and system configuration restore uploads are almost a daily task for this Laptop, without any problems until recently.

Usual browser is Firefox, but also tried with Vivaldi. Then tried with Brave and Chrome.
Also tried incognito/private browsing mode in all above browsers without any extensions running - still no file selection.

Been using the same User account (the only User account) for over 4 years so for checking added a new User (Standard) account. Log Out, then Log in with new User -ALL browsers will upload fine when using a new User account. No changes made, just a different User on the same machine.

Could it be a recent update? Would it affect User Accounts?

Laptop is running F39 workstation currently, first installed Fedora 30 when new, and upgraded to F39. All updates are applied as and when indicated by system notifier.