How to make files selected info text readable in Files when using dark theme?

From Fedora 30 - 36, it never worked, in my Files, if I selected multiple files/directories, at lower right corner, there is a floating message showing how many files selected. I am just using default dark theme.

It is not readable when Files window is activated
It is somewhat readbale when Files window is deactivated

How can I fix that ? ( see address bar too, it has the same issue)

I haven’t seen that before. Maybe there are some legacy theme customizations under ~/.config/gtk-4.0?

If you create another account with a default/empty home directory, does it exhibit the same problem? If not then the problem is likely some config file under your home directory. But if the problem persists, then it is probably a global setting somewhere.

Edit: This might be a useful reference for how to tweak (or untweak) the theme: GTK - ArchWiki (not sure, I’ve never messed with it).

1 Like

It is working well on Fedora 37, but then that is using a nautilus version rewritten for GTK4. Indeed, trying with a temporary blank account will confirm whether this is a general issue, or something related to your own account.

It is working as expected now, I upgraded to F37, but not sure if it is the upgrade helped or below.
I found I have a ~/.config/gtk-4.0/settings.ini


That’s all the content inside it, I changed it to 1

It is easy enough to set it back to 0 to see whether that indeed re-introduces the issue. However, I am inclined to assume that it still will work after the upgrade with the setting left to default.

I tried setting the value back to 0, but it did not reintroduce the issue, I am confused now. as the issue was still there after my F37 update, it was always there, I started using Fedora at around 30, but I do not remember since when that issue started, at least it was there between F34-F37, I did not do clean new install but always upgraded.

The likely reason for this was mentioned before.