F34 - Apps With White Text - Dark Mode



Does anyone know how to fix this? This occurs on GNOME dark mode. (I’m more concerned with my other apps, not notepad because I have notepad ++ installed and it doesn’t have this problem)

I’ve tried searching but the only post I’ve found older posts referring to Firefox, gtknotepad:

I’ve tried messing around with Gnome tweaks but didn’t find a setting that would have fix this issue.

I think it has to do with Icon Theme: Adwaita not being set to dark mode? However, I don’t have the option to change that

[gns3@gns3:~]$ screenfetch
/:-------------:\ gns3@gns3
:-------------------:: OS: Fedora 34 ThirtyFour
:-----------/shhOHbmp—:\ Kernel: x86_64 Linux 5.13.7-200.fc34.x86_64
/-----------omMMMNNNMMD —: Uptime: 50m
:-----------sMMMMNMNMP. —: Packages: 2050
:-----------:MMMdP------- —\ Shell: bash 5.1.0
,------------:MMMd-------- —: Resolution: 1920x1080
:------------:MMMd------- .—: DE: GNOME 40.0
:---- oNMMMMMMMMMNho .----: WM: Mutter
:-- .+shhhMMMmhhy++ .------/ WM Theme:
:- -------:MMMd--------------: GTK Theme: Adwaita-dark [GTK2/3]
:- --------/MMMd-------------; Icon Theme: Adwaita
:- ------/hMMMy------------: Font: Cantarell 11
:-- :dMNdhhdNMMNo------------; Disk: 2.4T / 8.2T (29%)
:—:sdNMMMMNds:------------: CPU: Intel Core i7-8750H @ 12x 4.1GHz [65.0°C]
:------:://:-------------:: GPU: Mesa Intel(R) UHD Graphics 630 (CFL GT2)
:---------------------:// RAM: 4004MiB / 31773MiB

gsettings set org.gnome.gedit.preferences.editor scheme "oblivion"

I’m afraid there’s no single solution and each app should be fixed separately.
You’d best to file a ticket to notify the developers of the issue:
Something bugging you in Fedora Linux? Let's get it fixed! - Fedora Magazine

1 Like


This fixed my notepad!

But my other app (GNS3) still has white text on a white background


I found this link:

I’ll try this messing around with the settings and see if this will fix the issue, thank you for helping me with the notepad issue

1 Like

I fixed GNS3 by changing it’s theme following that GitHub project, I never even knew this project existed, which is sweet cause it looks much better now!

Now I have to Google how to fix this problem lol, appreciate the help