Unable to boot Fedora in Virtualbox (restored from a Clonezilla backup, made on another machine)

I backed up my former system with Clonezilla and found restoring in Virtualbox (with the ‘guest additions’ installed) to be the most convenient way to recover some files. Both computers are amd64, but the other was using AMD hardware (I installed Vulkan drivers from the Fedora repo at some point) while the current has an Intel CPU. I booted/installed the Clonezilla ISO as fedora-x64 and removed the disk image from the VB’s storage devices after the restoration.

The recovery process seemingly finished without errors, but when booting the virtual system I receive this message:

FATAL: Could not read from the boot medium! System halted.

I can boot in EFI, but I assume that my access there is limited, especially as a novice user.

Additionally, I haven’t quite understood if a virtual machine is able to boot without any storage device (to make myself clear, I installed the Clonezilla backup into this machine and don’t need any boot media anymore):

1 Like

In this related video, the .vdi file is enabled as the SATA device in Virtualbox.

You may need to reinstall/restore GRUB.

1 Like

The UEFI shell doesn’t recognize the dnf command and I don’t know how I could proceed. The ‘Solving problems with UEFI bootloader’ paragraph wasn’t an immediate solution either and the command lsblk, again, is not recognized (not visible in my screenshot, but the same error message).

Boot Fedora live session mounting the ISO image in the virtual CDROM.

1 Like

Thanks, I’ve now done so.

By any chance, could I actually access the files from the restored Clonezilla image using this live ISO? I don’t really have to ever boot my former installation per-se, I could retrieve almost everything by browsing the filesystem.

1 Like

Yep, it should be possible.

If I yet may ask, could you point me to the right direction (disk partition?)? Should the data be accessible and the path(s) shown in the file explorer?

baobab and ‘disks’ screenshots:

Check out this:

sudo vgs; sudo pvs; sudo lvs; lsblk -o +FSTYPE
loop0         7:0    0  1.8G  1 loop /run/media/liveuser/disk squashfs
loop1         7:1    0  7.5G  1 loop                          ext4
├─live-rw   253:0    0  7.5G  0 dm   /                        ext4
└─live-base 253:1    0  7.5G  1 dm                            ext4
loop2         7:2    0   32G  0 loop                          DM_snapshot_cow
└─live-rw   253:0    0  7.5G  0 dm   /                        ext4
sr0          11:0    1  1.9G  0 rom  /run/initramfs/live      iso9660
zram0       252:0    0  1.9G  0 disk [SWAP]
1 Like

That’s weird, the disk type storage is missing.
Check the VM storage configuration.

Does this give any clue? I’ve tried to entirely use the default settings and haven’t intentionally changed anything storage-related.

There is no (virtual) hard drive connected to your machine. It should appear under SATA controller. Go add it by clicking on the green + symbol, choose the disk you need (extension .vdi or .vmdk).


I reinstalled with more care and a storage device now appears under the SATA controller, but I get the “No bootable medium found!” when attempting to start the machine.

Is it necessary to manually add the IDE controller when restoring a (Clonezilla) backup? I can’t select/see any files in the VM data path ~/VirtualBox VMs/clonezilla.

I finally got access by booting a live Fedora ISO (the version shown in the image above) and mounting a volume displayed in the file explorer’s ‘other locations’ tab:

/dev/dm-3 appears to host the desired data (in the user parent directory). virtualbox-guest-additions from the Fedora software repo may make transferring easier.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.