Fedora in emergency mode on both disks after clonezilla

Hi guys, i need some help repairing my fedora boots after using clonezilla. Any help would be appreciated

Provide more information please. Like your Fedora version, your partition layout and format and what did you exactly do.

Thanks for responding.

My fedora version is 37 for both disks.

I’m not entirely sure how I’d list my disk layout from emergency mode, perhaps you can help me with that if you have the patience.

I had run clonezilla in basic mode copying all the data from my 500gb drive to my 2tb one. Both are connected to my motherboard. I ran disk_to_local_disk local_disk_to_local_disk mode.

I can also launch into a bootable drive and open my original fedora drive that i cloned from. However the one i cloned to gets an error that reads "an error occured while accessing ‘Fedora 1’, the system responded: requested operation has failed: error mounting /dev/sda2 at /run/media/liveuser/fedora 11: mount(2) system call failed: file exists

If possible I’d like to get at least my 500gb drive working (the original)

Okay i think i figured it out. it was duplicating the disk and causing an error. Clonezilla didn’t provide the kind of copy i was hoping it would (Instead of having to redo all my install steps on a brand new drive).

I’m going to start from scratch in that case and work on it daily.

Clonezilla probably did a full copy including UUIDs for the drive and partitions which would prevent booting when both drives were attached.

The solution may be as simple as disconnecting the original drive then booting from the clone. Or it may be as complex as doing a repair (also with the original drive disconnected).

I have not tried what you describe with clonezilla, so cannot be sure. Disconnection of the original drive (after verifying UUIDs it contains) then comparing those UUIDs to the ones on the new drive would be a start. Look at the drive UUID as well as the file system UUIDs and at the UUID that displays in /boot/efi/EFI/fedora/grub.cfg and for the /boot partition and the /boot/efi partition. Look also at the UUIDs shown in /etc/fstab.

A direct copy as you did would require all the UUIDs to match before you could boot from the clone, and that the original disk did not conflict.

So because clonezilla makes a perfect clone, the mount point seems to be exactly the same and it causes the system confusion so it seems.

There’s probably a way to fix this by changing the fstab file i’m guessing, but I don’t think it’s worth it. With a little bit of work and effort today I managed to bring my installation to the new drive. Pretty much everything needed is in the home folder.

Thanks for your help.