Unable to add more than 1 picture to background


fedora 36 gnome 42.2

settings > appearance > background > add picture

unable to add multiple pictures to backgrounds at once, can add only 1 image at a time.

which means if i have 20 wallpaper images in a folder i have to add them 1 by 1 20 times to background in appearance.

this problem has surfaced with fedora 36, with fedora 35 i could add all images / multiple selected images from a folder at 1 go.

1 Like

I don’t think so. You can copy them direct to /usr/share/backgrounds/your-folder Then they should be available all at once.
Just do it as sudo/root and control that your new sub-folder there has the same owner/user rights as the other once.

If you do this way you have them system wide available. If you copy them from your home/pictures they are just for your user available and just when you are logged in.

An alternate way to do this …
they are also in the user directory

You could copy them there
put a backgrounds directory in ~/Pictures and softlink to it from ~/.local/share/


why do i need to do these extra procedures in hidden files for something that worked flawlessly in fedora 35 via settings > appearance > background > add picture ???

not really sure if this is a fedora issue or a gnome problem.

However it is, before we can talk about the why we need to know how exactly you try to do it and from which source folder to what destination you want to upload. And also how you made it in
F35. I think if you want to select more than one file you need to browse the folder.

If you don’t have the rights to do so this could be the reason why it is just possible to select one picture?!

So please more details, for a bug request we need to be able to reproduce the issue.

  1. copy all wallpaper images from external portable disk to pictures folder

  2. settings > appearance > background > add picture

  3. navigate to pictures folder

  4. select all images with ctrl+a OR hold down ctrl & click desired images

  5. click on open & and multiple images are added to backgrounds in appearance in settings IN 1 GO.

the option to select all images with ctrl+a OR hold down ctrl & click desired images does not work since fedora 36.

my OP was pretty self explanatory but am simplifying it for you to comprehend.

am the admin & the only user on the machine.

I think that this behavior is due to the redesign of the interface (what is it? libadwaita? gtk4?).
Maybe it worth a try to file an issue here: https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues, or start a discussion here: https://discourse.gnome.org


This was a gnome change from the gtk4 transition, I’m not sure if it was intentional or not. There has been an merge request submitted to add the functionality back.



it is the same on arch linux too :unamused:

got an update for gtk4 but still no fix.

The fix should be in gnome-control-center.
There is a new version in the testing repository

But as far as I can see, the merge request is not here.

@grumpey, I am not very well versed in these things, but why, if your change was merged, it is not included in the new version?


It was merged into the main branch, not the gnome-42 branch. I submitted another request this morning for the gnome-42 branch. Sorry, I didn’t realize I needed to do 2.


i got gnome-control-center 42.2-1.fc36

i guess i will wait for the upgrade to gnome-control-center 42.3-1.fc36

thank you very much, truly appreciate you helping out :+1:

1 Like

am now on gnome-control-center-42.3-1.fc36 but nothing has changed.

still cannot select multiple images from a folder at one go in settings > appearance > background > add picture

1 Like

hi joe,

is there a fix still in the works or this is how things will stay?

why would gnome remove a previously existing totally harmless functionality?

As stated in a previous post:

the link you posted :


has version gnome-control-center-42.3-1.fc36

which i too have now but the problem still persists.

i could be wrong but i think joe has made a merge request day before :


Yes. I linked the rpm package that was in the testing repository at the time. Now it is in the stable repository. And you have it.
And yes, this version 42.3-1 doesn’t contain Joe’s patch, because

Probably we have to wait for the next version.


According to the schedule 42.4 should release sometime in August.