Trying to install Fedora 37 as dual boot but keep getting error

I’m trying to install Fedora to my secondary SSD for a dual boot, but every time I select the USB in the Bios the very next screen says “[ 4.335756] dracut-pre-udev[685]: sh: line 1: /sbin/sysctl: no such file or directory”

Also, when trying “test media and start” it also stops doing anything after " [ ok] started systemd-rfkill.service - load/save rf kill switch status"

I’m certain my hardware isn’t the issue, at least I think not… My CPU is AMD 3900X and motherboard is Asus Tuf x570 plus wifi… I’m not really sure what’s going on, I previously had Ubuntu on the drive but had wiped it due to it not supporting my 7900 XT. Supposedly Fedora 37 supports the 7900 XT OOTB, so I wanted to try again… really was looking forward to learning Linux and utilizing specific AMD Linux only tools… Anyone know what I’m doing wrong or how I can get this working? My other OS is Win11 and I’ve already disabled Secure Boot… Any help is greatly appreciated.

Please confirm how your Fedora USB boot media is created.

By Fedora Media Writer? dd ? Other tools?

Are you booting in BIOS mode of UEFI mode? With Secure Boot enabled or Disabled?

I don’t think so. The upgraded driver available later may support that GPU, but not the one on the original release ISO of F37

F37 was released mid November 2022 after having been frozen for over a month waiting for a security fix, and that GPU seems to have been released in the US on December 13, 2022. The driver was not available for the first release of F37 and I am not 100% certain it is supported yet.

I have made my USB an installation media a few times using different ways. I tried using Etcher, Rufus, and Fedora media writer. The programs for making the iso/USB into installation media verify that the image is correct and without error. I have tried both UEFI, and Legacy BIOS, and with & without Secure Boot Enabled. Using "Start Fedora-Workstation-Live 37” and “Test this media & start Fedora-Workstation-Live 37” both result in the errors mention in my original post. The only option that worked is using “Troubleshoot>> Start Fedora-Workstation-Live 37 in Basic Mode” … However, when doing so my screen’s resolution is extremely limited and there is no sound, and when checking Fedora’s access to my 7900 XT it recognizes it but says access denied on all the lspci printouts in the terminal. I assume this is because I had to install using basic graphics mode, so I tried going about searching for a way to utilize my GPU and fix the sound, which led me down a rabbit hole a month old that said installing latest MESA and LLVM & editing something in the GRUB nomodeset would get it working… But, installing newest MESA and LLVM just resulted in black screens that prevented display before even reaching the GRUB bootloader which essentially borked my install, forcing me to switch back to Windows and wipe the drive again.

I’ve seen a dozen or so reports on reddit where people said they were able to install just fine and use their 7900 XT/XTX with the latest Fedora release and similar hardware as mine, so this led me to believe all was good to go. Even if the drivers aren’t updated for my card, that shouldn’t prevent me from installing the normal way though, right? Doesn’t explain why the only way I could install was via the Basic Graphics option…

Initial install, yes it may prevent normal graphics. Once the kernel and the driver are updated then it may work properly.

Why not do the install with basic graphics then immediately do an upgrade to the latest kernel and drivers followed by a reboot to see if that works. Installing other things before the graphics issue is solved may be simply creating more problems.

If you have seen those reports then please link to them since many of us may not desire to do the searches ourselves.

Note that “latest fedora release” does not necessarily mean the initial fedora 37 ISO. As I noted above, it was released before that GPU was even available.

I would suspect that many either did a net install or did an upgrade after the appropriate driver was available for the newer kernels. In either case the system installs the latest packages from the net and is not limited to what is on the ISO

I do not use an AMD GPU and certainly do not have the funds to invest in the “latest and greatest” of GPUs so I have no way to test what is happening to your system.

Remember that your GPU has only been available for less than 2 months as of today.