Trying to fix Touchpad Multitouch

Hello fellow fedora users

I have installed Silverblue on a Fujitsu Stylistic Q702, however for the last week i have been unable to figure out how to configure the touchpad on the keyboard dock to register multi touch.
I’ve tried setting a config through udev and libinput without any luck.
Please can you advise me of any good places to look to try and resolve this issue?

#libinput list-devices

Device:           HID 04c5:138b
Kernel:           /dev/input/event8
Group:            7
Seat:             seat0, default
Capabilities:     keyboard 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      n/a
Nat.scrolling:    n/a
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   n/a
Rotation:         n/a

Device:           HID 04c5:138b
Kernel:           /dev/input/event9
Group:            7
Seat:             seat0, default
Capabilities:     pointer 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   button
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   flat *adaptive
Rotation:         n/a

Device:           HID 04c5:138b
Kernel:           /dev/input/event10
Group:            7
Seat:             seat0, default
Capabilities:     keyboard 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      n/a
Nat.scrolling:    n/a
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   n/a
Rotation:         n/a

edit:

#udevadm info /sys/class/input/event9
P: /devices/pci0000:00/0000:00:14.0/usb3/3-3/3-3.3/3-3.3:1.1/0003:04C5:138B.0004/input/input9/event9
N: input/event9
L: 0
S: input/by-path/pci-0000:00:14.0-usb-0:3.3:1.1-event-mouse
S: input/by-id/usb-04c5_138b-if01-event-mouse
E: DEVPATH=/devices/pci0000:00/0000:00:14.0/usb3/3-3/3-3.3/3-3.3:1.1/0003:04C5:138B.0004/input/input9/event9
E: DEVNAME=/dev/input/event9
E: MAJOR=13
E: MINOR=73
E: SUBSYSTEM=input
E: USEC_INITIALIZED=4994081
E: ID_INPUT=1
E: ID_INPUT_MOUSE=1
E: ID_VENDOR=04c5
E: ID_VENDOR_ENC=04c5
E: ID_VENDOR_ID=04c5
E: ID_MODEL=138b
E: ID_MODEL_ENC=138b
E: ID_MODEL_ID=138b
E: ID_REVISION=0101
E: ID_SERIAL=04c5_138b
E: ID_TYPE=hid
E: ID_BUS=usb
E: ID_USB_INTERFACES=:030101:030102:030000:
E: ID_USB_INTERFACE_NUM=01
E: ID_USB_DRIVER=usbhid
E: ID_PATH=pci-0000:00:14.0-usb-0:3.3:1.1
E: ID_PATH_TAG=pci-0000_00_14_0-usb-0_3_3_1_1
E: LIBINPUT_DEVICE_GROUP=3/4c5/138b:usb-0000:00:14.0-3
E: DEVLINKS=/dev/input/by-path/pci-0000:00:14.0-usb-0:3.3:1.1-event-mouse /dev/input/by-id/usb-04c5_138b-if01-event-mouse

I’ve managed to isolate the udev rules to only modify the touch-pad part of the Keyboard dock using the following

#/etc/udev/rules.d/99-my-device-is-a-touchpad.rules
ACTION=="add|change", KERNEL=="event[0-9]*", \
ENV{ID_VENDOR_ID}=="04c5", \
ENV{ID_MODEL_ID}=="138b", \
ENV{ID_INPUT_MOUSE}=="1", \
ENV{ID_INPUT_MOUSE}="", \
ENV{ID_INPUT_TOUCHPAD}="1", \
ENV{ID_INPUT_WIDTH_MM}="70", \
ENV{ID_INPUT_HEIGHT_MM}="42"

Unfortunately it looks that Libinput then doesn’t accept the device any more, and the touch-pad stops responding all together.