Fedora 31 (KDE) cannot find touchpad on Asus FX503V


I am attempting to get my touchpad working on my Asus FX503V, but Fedora 31 does not seem to be able to find it, and it does not show up in KDE System Settings. I believe this to be a problem with libinput.

I have attempted to install Synaptics to replace libinput, which I now have installed, but I cannot figure out how to make Fedora switch to using it instead. It is not simply a matter of dnf remove xorg-x11-drv-libinput, as several key system components seem to rely on it.

Other forum posts I have found appear to have solved the problem with simply installing the drivers with dnf install xorg-x11-drv-synaptics*, but even after installing the drivers my touchpad is still not being detected or working. Another forum post suggests deleting libinput, but several packages rely on it.

This is not a hardware issue, as the touchpad works perfectly fine in Windows.

How would I go about getting my touchpad to work?

Maybe: acpi_osi=linux ?
2019-07-19 bbs.archlinux.org

Kernel parameters (list from admin-guide).