Trouble Installing Fedora 37 System Freezes - Intel Arc 770 GPU?

I just got a brand new NUC 12 Enthusiast and cannot get any operating system installed.

First, I added this RAM and NVME:

  • Crucial P3 Plus 1TB PCIe 4.0 3D NAND NVMe M.2 SSD, up to 5000MB/s - CT1000P3PSSD8

  • Crucial RAM 64GB Kit (2x32GB) DDR4 3200MHz CL22 (or 2933MHz or 2666MHz) Laptop Memory CT2K32G4SFD832A

These appear to work fine as far as BIOS reports.

I disabled Secure Boot and inserted a USB to install an OS from.

I have tried, several times, using Fedora 37 and Ubuntu 22 USB install to get an operating system onto this machine.

If I try to use Fedora 37, the system boots and crashes with this on the screen:

“[ 2.917246] dracut-pre-udev[717]: sh: line 1: /sbin/sysctl: No such file or directory”

I don’t know what this means.

Second, I tried Fedora 36 from USB. This resulted in “no bootable devices found” message on the screen.

Next, I grabbed Ventoy, formatted the USB, and put Fedora 37 bootable ISO on it. This got me through an install, but on reboot, the system freezes on the Fedora splash screen (the little spinning graphic isnt spinning, either, above the Fedora logo).

I tried again. I installed Fedora 36 (to update to 37 from there). Install goes fine every time, until I update. After sudo dnf update, the system freezes on boot again. If I do not update, it works fine, but its much outdated Fedora 36. I can replicate this behavior every single time with Fedora, it simply refuses to work after updating.

How can I fix this? I have no further idea of what to do other than return the NUC. It is a shame because my Hades Canyon works perfectly.

My only guess is there is some bug or driver regression in kernel 6 but others are able to install it… not sure what else to do.

Update 1:

I did a fresh install of Fedora 36 and ran dnf update but excluded anything named kernel* to prevent it from updating to kernel 6.x. The system still worked fine. I could install whatever I wanted and reboot consistently no problem.

I could not get sound working, however.

If I install Fedora 37, it refuses to boot. If I edit the boot params in grub and enter ‘nomodeset’ - it will boot into Fedora 37. The graphics report as “Software Rendering”.

I guess this is an issue in kernel 6.0.8 / some driver (?) and all I can do is wait for 6.1, and 6.2 (although this would be months without a usable machine?).

Update 2:

Based on the previous update, I gave this another shot.

I started from scratch did the following:

  • Formatted GPT partition with Ventoy on the USB stick

  • Added Fedora 36 ISO to the USB stick

  • Enabled Secure Boot and Intel TPM in the BIOS

  • There were no weird issues or restarts required this time (I did not format as GPT the first dozen times :frowning: )

  • Fedora 36 installed fine

  • I ran sudo dnf update --exclude=kernel* to get all available updates except kernel 6.0 so I could continue debugging.

  • After that, I rebooted a few times just to ensure it was stable

  • Then, I updated without excluding the kernel, and once I was on 6.0.8 the problem started again - system froze up.

  • I edited grub to set nomodeset every time I boot so I can at least get into Fedora without the system halting. I found two very curious things.

With “HD Audio” enabled in the system BIOS, the system will always freeze. After unsetting it, nomodeset is still required to get into Fedora without freezing. I have no idea why this is the case. Formatting as GPT is required:

Intel Arc Alchemist graphics cards will require your Operating System to be using the GPT partition type

I missed that the first go round.

After reading through journalctl logs, I disabled HD Audio in the BIOS and restarted. It still froze, but I continued with the following (the order was important):

  • Reboot and set nomodeset boot param at the grub menu

  • Edit /etc/gdm/custom.conf and uncomment WaylandEnabled=false - this forces X11

  • Reboot

  • lscpi -nnv | grep -A8 “VGA” now shows the Intel Arc 770 gpu and PCI ID

  • Edited /etc/default/grub and added i915.force_probe=5690 boot parameter

  • Reboot

Now it works!

On the About panel in Settings, it now correctly lists the Arc GPU in use.

Does anyone know what “HD Audio” is in this new system, and do I need it? It seems that this setting, and Wayland, are a problem that freezes the system. If I enable either one, I have to run down the list of steps again, in order, by editing grub with nomodeset. I could replicate that a few times.

The only remaining problem I can see is that I have no audio output to the monitor over DisplayPort. I can see sound in pavucontrol when playing a YouTube video, but hear nothing. The sound test runs, but also no audio. I am not sure how to fix that yet.

Update 3:

The i915.force_probe does not work after shutdown (only reboot), and has to have the grub edits done again in order. Sigh. It is not usable like this.

Is anyone aware of what the culprit is here? Do I have to wait for kernel 6.1 or 6.2? Why does the sound not work out of the monitor (its fine with the Hades Canyon on F36 + latest updates).

1 Like

This about the Kernel 6 could indeed be a problem.

There is an LTS kernel on copr. You might give this a try as a second option so that you can manage your system as you like.

kwizart/kernel-longterm-5.15 Copr

This is what I assumed, given that Intel Arc is brand new. I suppose the sound device has a similar issue (driver support).

I haven’t done this before, but is there a way I can grab the latest 6.1 kernel into Fedora 37?

Have you checked to see if there is a bios update for your motherboard.

Although not expressly supported you can enable the rawhide repo and install the latest kernel from there.

The repo is fedora-rawhide-repo and this is the content on my rawhide system

name=Fedora - Rawhide - Developmental packages for the next Fedora release
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-rawhide-$basearch file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-39-$basearch

instructions here

The latest rawhide kernel is 6.1.0 rc5 as of today.

I see, I will give that a shot. This is a brand new system so I can reinstall and start over if I need to.

This also could be related and why I have issues in 6.0:

I updated to Fedora 38 rawhide and all applicable packages. I still have no sound, and the i915.force_probe=* does not persist across shutdowns, only on a reboot. Otherwise, there is no way to get the system to boot into any 6.x based kernel for me without ‘nomodeset’ on boot parameters first. Not sure what to do at this point.