Video play back very slow and jerky

I have a intel a750 I added i915.force_probe=56a1 to the kernel. And when I play any video with VLC smplayer or video. It plays very slow and jerky and tearing. But if I remove, it works just fine. I used grub-customizer to add it. Was that how I add it

why are you adding that parameter if it works choppy then?

On the fedora Reddit fedora page someone posted this

Intel Arc (A750) GPU on Fedora - first impressions and words of warning

Hello everyone,

despite all warnings, I could not resist the temptation and ordered an Intel Arc GPU (A750), which I finally received today. For any fellow daredevils and interested people, allow me to share my first impressions with this new GPU on Fedora 37 Beta.

First things first: It does work (sort of…)

However, as was to be expected, the experience hasn’t been particularly smooth so far. For reference: My old GPU was an AMD RX 580, which until now always did serve me well in most occasions.

So, after reading Michael Larabel’s articles on phoronix 2 first, I did install the rawhide kernel (6.1) beforehand, since 6.0 is the minimum for running Intel Arc GPUs. The other requirements (mesa 22.2) were already met on vanilla Fedora or merely suggestions (linux-firmware-git).

Also adding the following kernel boot parameter is still essential, even on kernel 6.1:

i915.force_probe=56a1 (for the A750, any other Intel Arc would of course have a different pci id)

I also activated resizable BAR (reBAR) in my BIOS, which my CPU/Motherboard luckily support, as per Intel’s own suggestions.

The first disappointment came already on my first attempt to boot with the A750: Fedora freezes right before the gnome login screen (switching to a TTY is not possible anymore at this point)

After double checking all the settings and some troubleshooting attempts, it seems that GDM and/or Gnome Wayland Session are not compatible with my new GPU yet. I don’t know if this will be fixed by future driver updates from Intel or if this is actually a bug in GDM/Gnome.

The only workaround I found here so far is to bypass GDM and boot directly into a TTY and run startx to manually start a Gnome session in X11. Running gnome-shell --wayland manually from the TTY also freezes my PC. I also tried starting sway (which uses wayland as a display server) and it worked fine - so the problem doesn’t seem to be with wayland per se.

In terms of actual gaming performance, the results so far have also been sobering. I haven’t been able to test many games, but on Mesa 22.2 all of them crashed or didn’t even start. (both DX12 and DX11 Games)

With the latest mesa-git drivers from COPR I could at least get Cyberpunk 2077 to run. On Ultra (no raytracing) it ran with about 20 FPS, which is worse than with my old RTX 580.

So, all in all, to be honest, I was expecting to run into some issues but this has been really underwhelming so far. Not time for buyer’s remorse yet, but everyone thinking that Intel’s history of good driver support on Linux means that the reported issues with Intel Arc GPUs from Windows are not representative of how the cards perform on Linux right now should be warned: It’s still very early days for Intel Arc. I really hope Intel fixes these issues fast.

Edit: List of Games tested so far (all DXVK/VKD3D, none of them native), all worked fine on my RX 580

  • Arma Reforger - crashes at launch
  • DAYZ - crashes after launch
  • Kingdom Come: Deliverance - black screen after intro
  • Metro Exodus (Enhanced) - green screen after intro/ ray tracing not detected
  • Ready or Not - black screen/freeze after intro
  • Cyberpunk 2077 - works with mediocre performance/occasional glitches and crashes/no RT
  • AC:Syndicate - crashes after Intro
  • Far Cry 5 - does not launch
  • Mafia: Definitive Edition - black screen / freeze at launch
  • Portal 2 - works, but is old, of course
  • Insurgency: Sandstorm - freezes after Intro
  • theHunter: Call of The Wild - works and performs well, might be the only newer game that doesn’t cause any issues with Intel Arc on Linux

Tested 3D Applications (all native OpenGL/Vulkan):

  • Blender 3.3 - Eevee works without any issues so far, Cycles with OneAPI could not be tested because intel-compute-runtime can currently not be installed on Fedora 37, on Arch (through distrobox) the card/driver wasn’t detected as a compatible device
  • Godot 4 Beta - works alright, though I feel performance could be a little better
  • Unreal Engine 5.1.0 (Editor) - unusable, lots of weird colors and visual artifacts in the viewport


According to this thread on r/linux_gaming resizable BAR (which I have enabled in BIOS) might actually require Secure Boot to be enabled as well (which I currently have not because of the rawhide kernel). I will further investigate, if this makes any difference

Update 2:

Enabling Secure Boot didn’t change anything. I think reBAR was already active without it.

1 Like

One thing of note:
Just because someone posts what they experienced and suggests fixes does not necessarily mean you should follow their steps. If your system is not having problems then making changes as you have done may actually cause problems that did not previously exist.

Think before you leap !

Why I was adding it is to get davinci resolve 18 studio to work