Trackpad Misbehaving, Need HELP! Please!

I have been suddenly having weird trackpad issues and was expecting that some update might solve it in the future. I installed fedora 36 and it worked fine. upgraded to 37 and was going fine until one day when the trackpad started to misbehave.

the right click on my trackpad gets triggered automatically. Sometimes the fire rate is so high that as soon as I press ESC key it is triggered again.

I use obsidian, firefox and vscodium most of the time and while moving the trackpad around the context menu shows up randomly and sometimes I end up clicking some item in the context menu, sometimes a video stops playing and I think it is buffering but then I realize that the trackpad misbehavior paused it or when I am typing the cursor suddenly moves where the mouse pointer was resting in vscodium. Sometimes I press the ESC key and the context menu goes away and reappears in a blink of an eye. While moving across the folders in gnome I accidentally end up moving apps out of the folder as the cursor passes by it. Sometimes while browsing the web repeated misbehavior of the trackpad frequently lands me into the developer mode for inspection.

When I leave my laptop is IDLE and I return iI see the context menu has pooped up sometimes I see it flickering.

I used Fn+F10 to disable the trackpad and used an external mouse and faced no issue but whenever I reenable the trackpad I again face the same issue.

This happens very frequently, at least once in 2 mins and is very annoying.

I am desperately looking for a fix and trying to diagnose the issue but I am too newbie to do it. I tried every option out of 3 in gnome tweaks > keyboard & mouse > mouse click emulation fingers, area and disabled but the issue still persists.

This suggests it could be a hardware issue. Do you have another OS on your laptop that you can test the trackpad on? If you don’t, try booting a live image of Fedora 36 (since your trackpad used to work on that).