Touchpad has randomly timed chaotic behavior

Hey all, new to this forum so apologies for any failures in following customs.

I am working with a Dell XPS XPS 15 9575 (080D) and fedora 30. Since Fedora 28ish, I’ve had an issue where the cursor will jump around or not move at all while using the touchpad. The cursor does not jump or do anything erratic when I am not touching the touchpad. The start and stop of this behavior does not seem to coincide with anything in particular. When the chaotic behavior occurs, the cursor still responds to taps as if clicked, however, the cursor will often not move or act as if I am pressing the right mouse button/two finger tap to right click. The touchscreen seems to operate just fine.

I am not sure how I would go about troubleshooting this. In /proc/interrupts, I see the interrupt lines that are responsible for it (for me it is DELL080D:00 and idma64.1, i2c_designware.1 or at least these increment when I use the touchpad under normal circumstances), but these do not increment without me touching the touchpad.

Any assistance on troubleshooting this would be great! Thank you!

I have the same laptop and have been dealing with this issue since I purchased it.
I have tried replacing hardware(trackpad, system board), disabling touch on the screen and have pulled the latest libinput to see if there was a fix there and have found nothing. When the mouse stops working the movement is registered by the kernel, so it doesn’t seem like a hardware issue to me.
This happens in both xorg and wayland.
Some forums had reccomended disable hardware accel in google-chrome, but that didnt help either. Also was suggested to disable wacom, but tried that as well.

Will let you update thread if I figure anything out.

I kind of have the same issue with the input randomly taking over, tried Debian and Manjaro , all the same problem. The cursor just randomly starts jumping around and also clicking a couple of times within seconds closing programs or creating 20+ sticky notes in KDE ( Manjaro ), now I switched back to Fedora KDE. The only thing I noticed that it may have something to do with the convertible part of the laptop, connections or something. Also Fedora does not initialize the trackpoint, only removing the keyboard and reconnecting it does activate it , and only then the problems start. As I said completely random maybe for 30 minutes nothing and then suddenly it just starts messing about.
Windows 10 also runs on the system without these problems.

Distro history with all the same problems
Fedora Gnome
Manjaro KDE
Debian KDE

Lenovo X1 Tablet Intel m5-6Y57

Kernel log throws this

05/04/2020 22:49 kernel psmouse serio2: TrackPoint at rmi4-01.fn03/serio0/input0 lost synchronization, throwing 1 bytes away.
05/04/2020 22:49 kernel psmouse serio2: resync failed, issuing reconnect request
05/04/2020 22:49 kernel psmouse serio2: trackpoint: IBM TrackPoint firmware: 0x0e, buttons: 3/3
05/04/2020 22:49 kernel input: TPPS/2 IBM TrackPoint as /devices/rmi4-01/rmi4-01.fn03/serio2/input/input36

will report if i find more