Touchscreen driver setup F35

Hi, I got a Kogan D500 2in1 (cheap aussie tablet) which has a Silead touchscreen. Windows did not work, so to get the TS going I downloaded the driver pack from Kogan and tried the silead tools and methods by onitake on github but no success, keep getting initializie errors.
So I then tried all the fw in the linux folder but again no success,
It is not recognised by wayland of course so no testing can be done.
Under F34 I did get recognition by xinput but always got 32768 on coords when touched.
I have run out of things to try but would like to finish the job properly so any ideas on how to get it working is welcomed.

Hello @beaka ,
Welcome to the :fedora: linux discussion area! So to start, I understand you have Fedora Linux F34 on a tablet that is not working correctly WRT the touchscreen.
Some more details will be needed to get some help for you, and honestly I may not have the answer, but let’s get started. Is there some more info you can provide like the actual chip being used by both the tablet(CPU+GPU) and the touch screen(ASIC?)?

Hi Stephen, Thanks for the prompt reply.
The CPU is a Celeron N3350 with integrated Intel HD Graphics 500 i915. The touchscreen is a Silead x680 type controller. I am unsure if it is a 1680 or a 3680 as the linux driver looks for 1680 fw while the windows driver download is 3680.
I am having trouble logging in to the forum from the tablet as I forgot the password so am on another computer.
The Silead device is detected in ACPI and lsmod shows driver is loaded but the firmware doesnt load so there is no device created in system.
I did get a device dreated in F34 but the coords were all wrong so I upgraded to F35 but now the fw doesnt load and no device for wayland is craated eg< no xinput device listed, but is in ACPItool.
Hope that is clearer, will try to log in fom tablet to upload some reports.

1 Like