Telegram MTProto proxy problems

Described fully here: Cannot connect to MTProto proxies before connecting to a SOCKS proxy · Issue #25888 · telegramdesktop/tdesktop · GitHub

When I open Telegram, I cannot connect to any of MTProto proxies, unless I first connect to my local port-forwarded SOCK5 proxy first. After that, all proxies keep working until I quit Telegram completely (i.e. via the system tray). I tested with both official Telegram binary (latest version) and flatpak. The problem is really annoying.

I’m on Fedora 37 WS. The problem isn’t Telegram’s, as I tested the same static binary on Fedora 36 in a VM, and it works flawlessly.

What can be the problem?

Did you try this way?

Not working. BTW, thanks.

The problem is not with the proxies; they start working successfully after I connect to my local SOCKS5 proxy, but not before. Kinda weird.

P.S.: If it helps, the SOCKS5 proxy is located on, which port-forwards the traffic to a remote via SSH.

Did you see that it is a newer Telegram app needed to do the settings as explained on the manual above. Then you should be able to start it automatically. At least as I understood the manual.

If I understood correctly, you mean my Telegram app is outdated. No, it’s one of the latest versions (v4.6.2).

Although it shouldn’t make a difference, but I did configure it manually (after doing automatically via the default trigger) and no luck.