System-upgrade reboot has no effect

I’m trying to upgrade from 29 to 30 (I had already succesfully upgraded from 28 to 29 in the past).

I did all the commands as indicated in DNF System Upgrade :: Fedora Docs, downloaded all new packages, and then sudo dnf system-upgrade reboot. No error messages.

However, when rebooting, after typing the disk encryption password, nothing happens. It’s as if I had never typed sudo dnf system-upgrade reboot in the first place. If I retry all upgrade commands, it tells me all packages are already downloaded, and once again I can try system-upgrade reboot, and rebooting does nothing.

Unless there is an error message very early in the boot process (and it scrolls too fast to be seen), there is nothing indicating why the upgrade doesn’t start.

Is there a way to force an upgrade after logging in? Or to diagnose why the upgrade process is not happening?

By the way, I should mention my system does not start a graphical interface by default. After boot, I type my user/password and then run startx manually (Nvidia’s fault, don’t ask). But I don’t see why that should prevent the upgrade process from taking place, since it happens before loading X.

Hello @dhekir Welcome to the community! Please do take a few minutes to go over the introductory posts in #start-here when you have the time. They contain lots of useful information.

That will be the problem:

  1. Enable your system to startx by default:

Set a default target

systemctl set-default

  1. Reboot and Start the process again

  2. Why your system don’t start automatically? see log and try to find any problem


@hhlp are you sure?
All in all, @dhekir is using the system like if it is a machine without a DE. Upgrading the release with DNF should work even without a graphical interface. Isn’t it?

Thanks for the indication. It’s not ideal, though, because the reason I changed my default target is because X crashes if I boot directly to it. It’s due to an Nvidia driver, but the only way I found it to work is to start without X, login, run startx, then I get an error message but the X server starts anyway. A direct boot results in a failure to start X and then I can do nothing else.

After posting my message (and before seeing your reply) I did find out about journalctl, so I looked at it and saw a message about the reboot, then I found this discussion on a mailing list that pointed me to the probable cause, so I removed the “3” I had put in the /etc/grub/grub.cfg file and rebooted, but still it didn’t work.

I eventually found out that I was able to run directly system-upgrade upgrade, since all the previous steps had worked, and I was not in a graphical interface anyway, so I just ran it directly and it worked. I still have the X crashing as before, but at least I could upgrade to Fedora 30.

I’m afraid your solution might not have worked, since rebooting after changing the default target would produce the crash on X and then freeze, forcing me to go back to the command-line just to be able to run the system upgrade, so I detailed my solution in case someone else might want to try it.

I don’t know When system upgrade take control before or after gdm start and show plymounth screen that problem depend of this…


Resolved, or at least circumvented.

I removed 3 from the grub stanza and did a grub mkconfig. I also removed quiet so I can see what’s going on. dnf system-upgrade reboot did not work, but after the grub changes dnf system-upgrade upgrade does work. Not sure what’s going on, but I guess I don’t care. At 29 now and upgrading to 30.

Leaving this in case anybody has has a similar issue. Thanks.

This does not work for me. I get a message something like “trigger file not found, exiting silently.”

Can anybody help with this please?

I have two Fedora 28 boxes. Both have gdm disabled but one has the console messages displaying during boot… I can’t remember how I set it and the box is offline in another country right now. I had no problems system-upgrade (ing) that one from 28-29 and then immediately 29-30.

The laptop I’m using right now does not have console message display during boot and same situation as dhekir, dnf system-upgrade reboot has no effect, I just get a normal console logon prompt. I am running nvidia drivers on this box, so I have the same problem he reported. Unfortunately, the system-upgrade upgrade command fails for me with the message I mentioned.

There is not enough information to figure out what the /system-update symlink is supposed to point to.

I would be happy for a straightforward workaround, but I also wonder how system-upgrade for servers with no GUI works, if this depends on graphical boot.

By the way, setting a graphical target in systemctl changed nothing for me. It still boots to command line. I guess I changed grub at some point and but it seems like systemctl should override that.