Upgrade from f27 to f28 doesn't take place

Dear co-fedora users,

At the moment I am running f27 and I would like to upgrade it to f30. I followed the steps described below as described in fedora wiki.

  1. sudo dnf upgrade --refresh
  2. sudo dnf install dnf-plugin-system-upgrade
  3. sudo dnf system-upgrade download --refresh --best --allowerasing --releasever=28
  4. sudo dnf system-upgrade reboot

Note that I tried to gradually upgrade to the next release instead of upgrading directly to f30, since from previous experience (i.e. when wanting to upgrade from f24 to f27) I’ve found out that it was smoother and safer.

After performing the dnf system-upgrade reboot command, my laptop rebooted, the upgrade screen when on and eventually I was booted again in f27 while there is not f28 option on the boot menu. I therefore tried to understand the issue by doing the following :

  1. I had a look at /boot in case there is any file ralated to f28 but there is nothing there as well.
    I also checked the /boot/grub2/grub.cfg file and there isn’t any entry related to f28 either. So I guess the issue, it’s not related to grub .

  2. I checked with journalctl -r -p err but I couldn’t see something helpful there, either apart from the following entry
    systemd[1]: Failed to start System Upgrade using DNF.
    which doesn’t specify why it failed to upgrade.

  3. I checked the dnf.log file, which can be found here. I saw some critical errors there, but I am not sure what to do. For example

    2019-06-28T05:43:26Z CRITICAL Error opening file for checksum: /var/lib/dnf/system-upgrade/fedora-f21308f6293b3270/packages/compat-libicu57-

    2019-06-28T05:43:26Z CRITICAL Package “compat-libicu57-57.1-2.fc28.x86_64”
    from repository “fedora” has incorrect checksum

  4. I run sudo dnf repolist all and it seems that some repositories are disabled

    I am wondering if there is a way to enable them.

  5. I enabled the disabled repositories by editing the .repo files in /etc/yum.repos.d and changing the value of enable to 1 in the cases where it was 0 and then repeated sudo dnf upgrade --refresh, sudo dnf system-upgrade download --refresh --best --allowerasing --releasever=28 and sudo dnf system-upgrade reboot. Still the dnf.log gives me the same critical error seen in 3.

Any idea what to do next in order to eventually upgrade to f30 ?

Thanks in advance!


I’m new to fedora myself (started with f29, just before 30 came out), but if you don’t to go straight to 30; I would suggest trying to update to f29. Only guess but I suspect your issues may be being caused by the fact that both f27 & f28 are EOL.

Thanks Tom.

Thank you very much for your reply.
It seems that the issue was a corrupted file.

The problem was the compat-libicu57- 57.1-2.fc28.x86_64.rpm file which was saved in


The critical error that was encountered was referring to an incorrect checksum.
To solve the issue the following steps were followed

  1. The /var/lib/dnf/system-upgrade/fedora-f21308f6293b3270/packages/compat-libicu57- 57.1-2.fc28.x86_64.rpm file was deleted
  2. I downloaded the compat-libicu57- 57.1-2.fc28.x86_64.rpm file from rmpfind.net
  3. I moved the downloaded .rpm file to /var/lib/dnf/system-upgrade/fedora-f21308f6293b3270/packages/
  4. I then run sudo dnf system-upgrade reboot and the system was upgraded to f28