System Freeze after start / on login

Hey,

sometimes when I start my computer and open Firefox, the computer totally freezes. No reaction to neither mouse nor keyboard. I have to force shut down the computer and restart it and then it operates normally again.

Update: Today the system also crashed after entering my password and pressing enter. Nothing happened and I had to restart with the power button.

In the Problem reporting tool the System Failure shows up:

Reason: general protection fault, probably for non-canonical address 0x2ff93cfb606af40: 0000 [#1] PREEMPT SMP NOPTI

Backtrace:

general protection fault, probably for non-canonical address 0x2ff93cfb606af40: 0000 [#1] PREEMPT SMP NOPTI
CPU: 10 PID: 3049 Comm: Sandbox Forked Not tainted 6.0.18-300.fc37.x86_64 #1
Hardware name: Micro-Star International Co., Ltd MS-7C02/B450 TOMAHAWK (MS-7C02), BIOS 1.I0 07/25/2022
RIP: 0010:folio_memcg_lock.part.0+0x31/0x140
Code: 55 48 89 fd 53 48 8b 47 38 a8 01 75 71 48 8b 55 00 a8 02 75 7a 80 e6 02 0f 85 ac 00 00 00 48 83 e0 fc 48 89 c3 48 85 db 74 77 <8b> 83 40 0f 00 00 85 c0 7e 6d 4c 8d a3 48 04 00 00 4c 89 e7 e8 96
RSP: 0018:ffffbd0145f07a38 EFLAGS: 00010206
RAX: 02ff93cfb606a000 RBX: 02ff93cfb606a000 RCX: 0000000000000000
RDX: c717ffffc0080014 RSI: ffff93d044386bb8 RDI: fffff853c6fa5d00
RBP: fffff853c6fa5d00 R08: ffff93d044386bb8 R09: 00007f24cb9ff000
R10: ffff93cf8bcfdd80 R11: 0000000000000901 R12: ffff93d044386bb8
R13: ffffbd0145f07b80 R14: 00007f24cb9d2000 R15: 00007f24cb9d1000
FS:  00007f24ce0846c0(0000) GS:ffff93d2aec80000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 00007f2504efa450 CR3: 0000000138332000 CR4: 00000000003506e0
Call Trace:
 <TASK>
 page_remove_rmap+0x18/0x550
 unmap_page_range+0x7e9/0x12e0
 unmap_vmas+0x8d/0x100
 exit_mmap+0x9a/0x1b0
 __mmput+0x49/0x130
 begin_new_exec+0x4b3/0xb30
 load_elf_binary+0x2c2/0x1790
 bprm_execve+0x272/0x630
 do_execveat_common.isra.0+0x1ad/0x230
 __x64_sys_execve+0x32/0x40
 do_syscall_64+0x5b/0x80
 ? handle_mm_fault+0xae/0x290
 ? do_user_addr_fault+0x1ef/0x690
 ? exc_page_fault+0x70/0x170
 entry_SYSCALL_64_after_hwframe+0x63/0xcd
RIP: 0033:0x7f2504efa45b
Code: Unable to access opcode bytes at RIP 0x7f2504efa431.
RSP: 002b:00007f24ce083878 EFLAGS: 00000246 ORIG_RAX: 000000000000003b
RAX: ffffffffffffffda RBX: 00007f24bf1f8980 RCX: 00007f2504efa45b
RDX: 00007f24bef21800 RSI: 00007f24bf1f8980 RDI: 00007f24bef60a80
RBP: 00007f24c15eca48 R08: 0000000000000000 R09: 00007f24bef01118
R10: 1999999999999999 R11: 0000000000000246 R12: 0000000000000008
R13: 00007f24c143794c R14: 0000000000000007 R15: 00007f24ce0838a0
 </TASK>
Modules linked in: uinput snd_seq_dummy snd_hrtimer nft_objref nf_conntrack_netbios_ns nf_conntrack_broadcast nft_fib_inet nft_fib_ipv4 nft_fib_ipv6 nft_fib nft_reject_inet nf_reject_ipv4 nf_reject_ipv6 nft_reject nft_ct nft_chain_nat nf_nat nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 rfkill ip_set nf_tables nfnetlink qrtr sunrpc vfat fat intel_rapl_msr snd_hda_codec_realtek intel_rapl_common snd_hda_codec_generic ledtrig_audio snd_hda_codec_hdmi edac_mce_amd snd_hda_intel kvm_amd uvcvideo snd_intel_dspcfg videobuf2_vmalloc snd_intel_sdw_acpi videobuf2_memops kvm snd_hda_codec snd_usb_audio videobuf2_v4l2 snd_hda_core videobuf2_common snd_usbmidi_lib snd_rawmidi snd_hwdep irqbypass videodev rapl snd_seq snd_seq_device snd_pcm joydev mc snd_timer wmi_bmof pcspkr k10temp snd i2c_piix4 soundcore gpio_amdpt gpio_generic acpi_cpufreq zram amdgpu drm_ttm_helper ttm iommu_v2 crct10dif_pclmul crc32_pclmul gpu_sched crc32c_intel drm_buddy polyval_clmulni polyval_generic
 drm_display_helper ccp r8169 ghash_clmulni_intel cec sp5100_tco wmi ip6_tables ip_tables fuse

Any ideas how to fix the issue?

sry to bother , but can you please tell me how are your logs are colored , when i use journalctl and save as text , it does not look like the way it was in terminal.