Fedora freezes after boot login


Fedora 35 gnome workstation freezes sometimes after boot login with a grey screen. Then I have to shut down the laptop using the power button. I updated the system multiple times but the issue is not solved. Is anybody having similar issues? Is there any solution? I am using dell g5 se with amd CPU and GPU smartshift.

Can you provide us more information like hardware info and if you can then provide inxi -Fxz in </>
So we can look into the issue you have.

I had something similar, but updating kernel fixed it.

  Kernel: 5.16.9-200.fc35.x86_64 x86_64 bits: 64 compiler: gcc
    v: 2.37-10.fc35 Desktop: GNOME 41.4 Distro: Fedora release 35 (Thirty Five)
  Type: Laptop System: Dell product: G5 5505 v: 1.9.0
    serial: <superuser required>
  Mobo: Dell model: 0JT83K v: A02 serial: <superuser required> UEFI: Dell
    v: 1.9.0 date: 08/26/2021
  ID-1: BAT0 charge: 40.9 Wh (100.0%) condition: 40.9/51.0 Wh (80.2%)
    volts: 12.6 min: 11.4 model: BYD DELL M4GWP0C status: Full
  Info: 8-core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64
    type: MT MCP arch: Zen 2 rev: 1 cache: L1: 512 KiB L2: 4 MiB L3: 8 MiB
  Speed (MHz): avg: 1397 high: 1398 min/max: 1400/2900 boost: enabled
    cores: 1: 1397 2: 1398 3: 1397 4: 1397 5: 1397 6: 1397 7: 1396 8: 1397
    9: 1397 10: 1397 11: 1397 12: 1397 13: 1398 14: 1397 15: 1397 16: 1396
    bogomips: 92626
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
    vendor: Dell driver: amdgpu v: kernel bus-ID: 03:00.0
  Device-2: AMD Renoir vendor: Dell driver: amdgpu v: kernel
    bus-ID: 07:00.0
  Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 3-2:3
  Display: wayland server: X.Org compositor: gnome-shell driver:
    loaded: amdgpu,ati unloaded: fbdev,modesetting,radeon,vesa
    resolution: 1920x1080~60Hz
    renderer: AMD RENOIR (DRM 3.44.0 5.16.9-200.fc35.x86_64 LLVM 13.0.0)
    v: 4.6 Mesa 21.3.6 direct render: Yes
  Device-1: AMD Navi 10 HDMI Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 03:00.1
  Device-2: AMD Renoir Radeon High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 07:00.1
  Device-3: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Dell
    driver: snd_rn_pci_acp3x v: kernel bus-ID: 07:00.5
  Device-4: AMD Family 17h HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 07:00.6
  Sound Server-1: ALSA v: k5.16.9-200.fc35.x86_64 running: yes
  Sound Server-2: PipeWire v: 0.3.45 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Dell driver: r8169 v: kernel port: 2000 bus-ID: 05:00.0
  IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 vendor: Rivet Networks Killer™
    driver: iwlwifi v: kernel bus-ID: 06:00.0
  IF: wlp6s0 state: up mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-3.1:6
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 2.29 TiB used: 1.34 TiB (58.4%)
  ID-1: /dev/nvme0n1 vendor: SK Hynix model: BC511 NVMe 512GB
    size: 476.94 GiB temp: 42.9 C
  ID-2: /dev/sda type: USB vendor: Toshiba model: MQ04UBD200 size: 1.82 TiB
  ID-1: / size: 320.55 GiB used: 304.18 GiB (94.9%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-2: /boot size: 975.9 MiB used: 279.4 MiB (28.6%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 80.2 MiB (13.4%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 320.55 GiB used: 304.18 GiB (94.9%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 62.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  GPU: device: amdgpu temp: 46.0 C fan: 65535 device: amdgpu temp: 46.0 C
  Processes: 452 Uptime: 3m Memory: 15.05 GiB used: 2.99 GiB (19.9%)
  Init: systemd runlevel: 5 Compilers: gcc: 11.2.1 Packages: 7
  note: see --pkg Shell: Bash v: 5.1.8 inxi: 3.3.12

Hi, look like your system already have latest kernel version installed. If the problem still comes, may be you want to read this post.

If it happen only on certain actions like shared link above, on Fedora Workstation you can use:

# Add kernel parameter
sudo grubby --args="amdgpu.dpm=0" --update-kernel=ALL

then reboot.

To remove above parameter if nothing change:

# Remove parameter
sudo grubby --remove-args="amdgpu.dpm=0" --update-kernel=ALL

I tried this. My laptop was getting stuck in shutting down and booting. So I removed the parameter.