Super key is not working on DELL XPS 13" and Fedora 33

Hey guys, super key is not working when using the built-in keyboard, it is working when using an external keyboard.
Tried some solutions I found on the web related to unity and others related to localectl with no luck :frowning:.

Hope this gets solved soon.
Thanks :pray:

1 Like

If an external keyboard works, it’s not a software issue, it’s hardware. Try popping the keycap off, to make sure there isn’t anything stuck under there that’s blocking it, and putting it back on. (Don’t worry about breaking anything, they’re designed to make this safe and easy.) If that doesn’t help, and it’s still under warranty, take it back to the dealer for replacement.

This worked perfectly fine on Windows before I changed to Fedora.
It’s worth mentioning that it didn’t work on Ubuntu as well. Seems like a Dell XPS specific issue.
This article explains how to solve it but it’s outdated.

1 Like

Some solutions involve removing dell-super-key although when I try to remove it, it says that I don’t have it anyway.