Sudo dnf install broadcom-wl problems

Hello everybody
i am keen to work with Fedora. Unfortunately i cant get my wifi driver working.
While trying to install it with
sudo dnf install broadcom-wl
i just get the message:
Kein Treffer für Argument: broadcom-wl
Fehler: Es konnte kein Treffer gefunden werden.: broadcom-wl

I don’t really understand, what next steps i can take.
I already got my broadcom wifi drivers working on ubuntu and linux mint with the same laptop and wifi card.

I got the following wifi card
02:00.0 Ethernet controller: Broadcom Inc. and subsidiaries NetXtreme BCM57765 Gigabit Ethernet PCIe (rev 10)
02:00.1 SD Host controller: Broadcom Inc. and subsidiaries BCM57765/57785 SDXC/MMC Card Reader (rev 10)
03:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4331 802.11a/b/g/n (rev 02)

I am happy for any help!


Hello @girasol …! Welcome to the community! Please do take a few minutes to go over the introductory posts in #start-here when you have the time. They contain lots of useful information.

  2. This package are provided by rpmfusion:
❯ LANG=C dnf info broadcom-wl
Last metadata expiration check: 0:00:19 ago on Fri Mar  6 18:22:14 2020.
Available Packages
Name         : broadcom-wl
Version      :
Release      : 13.fc31
Architecture : noarch
Size         : 25 k
Source       : broadcom-wl-
Repository   : rpmfusion-nonfree
Summary      : Common files for Broadcom 802.11 STA driver
URL          :
License      : Redistributable, no modification permitted
Description  : This package contains the license, README.txt and configuration
             : files for the Broadcom 802.11 Linux STA Driver for WiFi, a Linux
             : device driver for use with Broadcom's BCM4311-, BCM4312-, BCM4313-,
             : BCM4321-, BCM4322-, BCM43142-, BCM43224-, BCM43225-, BCM43227-,
             : BCM43228-, BCM4331-, BCM4360 and -BCM4352- based hardware.
  1. How to enable it? →



you can try my programe to install broadcom driver from “System” category .

sudo dnf copr enable youssefmsourani/luniversalinstaller -y

sudo dnf install luniversalinstaller -y

I’m not a Big Lover of this kind of applications, there are a few out there… but is something to appreciate…


The principal reason is the $USER never know what this kind of Script doing on the System, if some problem occurs is very difficult to trace… and the problem if always for :fedora:



Thanks a lot for the quick answers.
In the meanwhile i installed the rpm fusion repository and could install the broadcom-wl afterwards.
Anyways i can still not use my wifi.
Happy for any news for next steps

1 Like

Could you provide more information? Can you see the interface but you are unable to connect?
What is the output of iwconfig?

This program does not bring anything new, it just automates work to make it easier, nothing more .

I did this program and others to make a more easy distribution based on Fedora, but it did not come out of my personal experience due to my inability to keep up with the rapid changes of Fedora.

These suggestions in the correct order to install broadcom driver (With all possibilities to succeed) @girasol

1-disable secureboot from bios/uefi and install rpmfusion repos.

2- update system and reboot/boot from last kernel.

sudo dnf update -y && reboot

3- install kernel-devel .and…

sudo dnf install kernel-devel kernel-headers @c-development

4-install akmod-wl .

sudo dnf install akmod-wl

5-reboot .


If that doesn’t work, provide this information .

(google translate)


Hello @alciregi and @youssefmsourani

thanks a lot for helping!
In the end it worked after just installing the rpm fusion repository and then installing the broadcom-wl. The first reboot didn’t do it.
After updating all the packagea and another reboot it finally worked.
So now i can properly start with Fedora(:


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.