Installing broadcom-wl from rpmfusion-nonfree corrupts system

Hi, i’m new to linux, and for the first distro i choose fedora 40. My laptop - hp pavillion 15. I had no wifi connection from fresh installment, so i figured out that i need broadcom-wl driver for my Broadcom bcm43142.
I downloaded rpmfree-free/nonfree repo, then rebooted. All was ok, so i continued and run sudo dnf install broadcom-wl. It installed 66 other packages (i guess dependencies), showed no errors.
I rebooted and things have gone bad. I lost my f buttons control on brightness level, sound device no longer worked (no sound and no option in settings, system really slowed down and cursor started drawing on screen from time to time and so on.
How do i fix it, what have i done wrong. I’m hoping for this community help, as i really want to stay on linux/fedora. Thanks for future help

Does wifi work? If it does, maybe it’s taking up additional PCI resources that then can’t be assigned to other devices.

I’d try adding this as a kernel option and rebooting:

pci='pcie_bus_perf,realloc,pcie_scan_all,big_root_window'

You don’t have to reboot when you enable rpm fusion, i don’t think it could been the problem but who knows. Luckily i have the same wifi card and the laptop but i don’t face any major issue I enable rpm fusion and install broadcom-wl and wifi works fine tho i face consistent disconnects which i don’t face that much on debian or it could been my imagination or wifi (remember my personally experience), this problem you are facing is very random it can be anything, You can try to uninstall braodcom-wl and use dnf update to update the system and reinstall broadcom-wl. I hope this help let me know if it works

We need more information. Do you dual boot with another OS and if so, does the other OS have keyboard issues? Does the problem go away after a power off restart? (Many system provide stripped down wifi drivers that are loaded alond with keybaord drivers at power-on. Your keyboard problem could be due to clash between the BIOS wifi and keyboard support triggered by the wifi installation.)

Linux keeps detailed records of recent package transactions in /var/log/dnf.log and older transactions in /var/log/dnf.log.N:

I happen to use broadcom-wl, so in this system I see (using the </> button at the top of the text entry box to preserve the formatting):

% grep broadcom-wl /var/log/dnf.log*
/var/log/dnf.log.1:2024-04-20T11:18:37-0300 DEBUG ---> Package broadcom-wl.noarch 6.30.223.271-22.fc39 will be upgraded
/var/log/dnf.log.1:2024-04-20T11:18:37-0300 DEBUG ---> Package broadcom-wl.noarch 6.30.223.271-23.fc40 will be an upgrade
/var/log/dnf.log.1: broadcom-wl                                     noarch  6.30.223.271-23.fc40                rpmfusion-nonfree                           24 k
/var/log/dnf.log.1:2024-04-20T11:48:43-0300 DEBUG Upgraded: broadcom-wl-6.30.223.271-23.fc40.noarch
/var/log/dnf.log.2: broadcom-wl                                   noarch 6.30.223.271-23.fc40                rpmfusion-nonfree        24 k
/var/log/dnf.log.3:2024-04-19T21:10:52-0300 DEBUG ---> Package broadcom-wl.noarch 6.30.223.271-22.fc39 will be upgraded
/var/log/dnf.log.3:2024-04-19T21:10:52-0300 DEBUG ---> Package broadcom-wl.noarch 6.30.223.271-23.fc40 will be an upgrade

This should tell you which dnf.log.N has the transaction that installed broadcom-wl. Then you can find the names of the other 66 packages and details such as whether each package was an upgrade or an install.

The broadcom-wl driver has to be compiled, so there will be lots of dependencies (compilers, -devel packages) needed to install the wl module, but they shouldn’t affect the operation of the system, so we need to look for other types of packages.

Another massive collection of data useful in sorting out problems is available using journalctl. For starters, run journalctl --no-hostname -b -p 3|cat in a terminal. You should read about the parameters in man journactl so you understand what they mean. For many systems, there will be some “errors” that are so common in PC’s designed for Windows that linux provides workarounds.

It is often useful to post (as pre-formatted text) the output from running inxi -Fzxx in a terminal. Someone using similar hardware may already know how to fix your problem, while others having problems will be able to find your post with a text search.

Finally, you should make sure you have installed all Fedora updates as well as the system vendor’s BIOS updates so you aren’t chasing a problem that has already been solved.

This is an extremely common support request, particularly with Macs. After following through with the rpmfree-/nonfree install, not only do I not have wifi, my bluetooth disables and I cannot access the internet connection through my phone.
Ive attempted this procedure about 6 times. Broadcom on Macs has always been a problem. I was successful on Mint because the necessary files for the wifi can be found on the live USB.

I use an iMac with wl, but also have ethernet and a USB wifi dongle.

You should start a new topic with a more specific title and enough detail to allow others to reproduce the issue:

  • hardware – post the output from runninginxi -Fzxxin a terminal (as pre-formatted text using the </> button at teh top of the text entry panel). This gives a full description of the hardware and can be found using search engines by others with similar hardware and issues

  • Fedora installer you used (Fedora version, Workstation, etc.). Have you been able to update the system with current Fedora packages?

  • resources available – can you download and install packages without WiFi (e.g., using ethernet, external USB WiFi dongle, etc.). This will help us propose a way to get wl working.