Still quick drain battery after setup nvidia-prime

Before using Fedora, I have used Ubuntu on my laptop. To get more battery life I switched to the integrated graphics and there were no problems. But now I’m using Fedora and there’s one problem: even after nvidia-prime setup still quick drain battery. I’ve setup it by following guides on RPM Fusion. I’m not sure but I think that nvidia graphics card still in use, but the “glxinfo|egrep “OpenGL vendor|OpenGL renderer”” command show this (my integrated graphics is AMD Vega 8):
OpenGL vendor string: X.Org
OpenGL renderer string: AMD RAVEN (DRM 3.39.0, 5.9.16-200.fc33.x86_64, LLVM 11.0.0)
What can be the problem?

1 Like

It seems your laptop has the AMD/Nvidia GPU chipset.
I cannot speak to the power demands of the integrated AMD but since you are not using the discrete nvidia GPU it seems that any extra power demands would be AMD related.

If you installed the nvidia-settings package from rpmfusion you could open that and see exactly what is in use. You could also use “inxi -Gxx” to see the GPU devices and drivers in use.

Yes, it has.

If it would be so, it wouldn’t quick drain battery on Ubuntu. Below you can see the screenshot of powertop on Ubuntu and Fedora (60% battery, settings the same and each uses tlp):


As you can see, the process “tick_sched_timer” uses about 2.36 W. I still think that NVIDIA card still in use, but I also checked the output from “inxi -Gxx” and it shows the same as before:


I can’t see what is in use in the nvidia-settings:

Looking at the powertop outputs, yes there is a lot more power demand, but the gpu (amdgpu on both) shows 0 ops/s.
The biggest single difference I can point to is the summary line. On the first it shows 175 wakeups/s and on the second it shows 1257 wakeups/s. The second is definitely more active and it does not seem GPU related but rather total activity related.

In fact on the first the amdgpu uses 393 mW and on the second it only uses 272 mW. The extra demand does not seem to be related to graphics at all.

Check if it is a cpu issue first. If you see lots of process in powertop “Overview” page named ‘setroubleshootd’ (check all the way down, not just those with highest power, because setroubleshootd is crazily spawing hundreds of processes), then you are affected by
Workaround I thought of (untill #1916652 bugzilla is fixed): anyone of the following: sudo pkill -SIGSTOP setroubleshootd or (not as good because flatpak update to 1.10 fixes a CVE) sudo dnf downgrade flatpak-selinux